summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeoffrey “Frogeye” Preud'homme2019-06-05 22:20:06 +0200
committerGeoffrey “Frogeye” Preud'homme2019-06-05 22:20:06 +0200
commit774159cc4c42960df3341aed9c208f040353f40d (patch)
tree2575264f4d2fc47336e559ffc9c5d744dba513e8
parent0e08fbe8d6488245d3b0c8d4beced812495ce775 (diff)
downloadaur-774159cc4c42960df3341aed9c208f040353f40d.tar.gz
Update to 0.6 + PKGBUILD improvements
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
2 files changed, 10 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c37f0b3e26f8..b8efbcabf948 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,14 @@
pkgbase = check-sieve
pkgdesc = Syntax checker for mail sieves.
- pkgver = 0.5
+ pkgver = 0.6
pkgrel = 1
url = https://github.com/dburkart/check-sieve
arch = i686
arch = x86_64
license = custom
- makedepends = git
- makedepends = gcc
- makedepends = make
- makedepends = bison
- makedepends = flex
- provides = check-sieve
- conflicts = check-sieve
- replaces = check-sieve
- source = check-sieve::git+https://github.com/dburkart/check-sieve.git#commit=2219f6fb48caf2d975f8843dc421c399e27d9e6d
- md5sums = SKIP
+ depends = gcc-libs
+ source = https://github.com/dburkart/check-sieve/archive/check-sieve-0.6.tar.gz
+ md5sums = 63345f1bc9afb1e54e335f8a99cdfad4
pkgname = check-sieve
diff --git a/PKGBUILD b/PKGBUILD
index 0fe13813348b..66c6116ccfb7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,24 @@
# Maintainer: Geoffrey Frogeye <geoffrey+aur@frogeye.fr>
pkgname=check-sieve
-pkgver=0.5
-_gitver=2219f6fb48caf2d975f8843dc421c399e27d9e6d
+pkgver=0.6
pkgrel=1
pkgdesc="Syntax checker for mail sieves."
arch=('i686' 'x86_64')
url="https://github.com/dburkart/${pkgname}"
license=('custom')
-groups=()
-depends=()
-makedepends=('git' 'gcc' 'make' 'bison' 'flex')
-optdepends=()
-provides=("${pkgname}")
-conflicts=("${pkgname}")
-replaces=("${pkgname}")
-backup=()
-options=()
-install=
-changelog=
-source=("${pkgname}::git+https://github.com/dburkart/${pkgname}.git#commit=${_gitver}")
-noextract=()
-md5sums=('SKIP')
+depends=('gcc-libs')
+source=("https://github.com/dburkart/check-sieve/archive/${pkgname}-${pkgver}.tar.gz")
+md5sums=('63345f1bc9afb1e54e335f8a99cdfad4')
build() {
- cd "${srcdir}/${pkgname}"
+ cd "${srcdir}/${pkgname}-${pkgname}-${pkgver}"
make
}
-#check() {
-# cd "${srcdir}/${pkgname}"
-# make test
-#}
-
package() {
- cd "${srcdir}/${pkgname}"
+ cd "${srcdir}/${pkgname}-${pkgname}-${pkgver}"
install -Dm755 check-sieve "${pkgdir}/usr/bin/${pkgname}"
install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
}