summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMayorBender2021-08-19 21:43:34 -0400
committerMayorBender2021-08-19 21:43:34 -0400
commit249ca35674530c33f9af356c9d96d1448cb7adad (patch)
tree7844f13380625158a53bfa01a65260f0959f9553
parent17211ff47b59e3a4933f581d6beecee3a40b29cf (diff)
downloadaur-check50.tar.gz
check50 v3.3.3
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD6
2 files changed, 10 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f00b56622c16..cd6c6739b539 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = check50
pkgdesc = This is check50, with which you can check solutions to problems for CS50.
- pkgver = 3.1.2
+ pkgver = 3.3.3
pkgrel = 1
url = https://github.com/cs50/check50
arch = any
@@ -8,17 +8,14 @@ pkgbase = check50
license = GPL
makedepends = python-setuptools
depends = lib50
- depends = python
- depends = python-bs4
+ depends = python-beautifulsoup4
depends = python-pyaml
- depends = submit50
- source = https://files.pythonhosted.org/packages/source/c/check50/check50-3.1.2.tar.gz
- sha256sums = e34d39c9a230e80dc2105737f64f9d93bcecb150e184fc70bff2ac849c5f9bd4
+ depends = python-jinja
+ source = https://files.pythonhosted.org/packages/source/c/check50/check50-3.3.3.tar.gz
+ sha256sums = 61995f43be54d6c90ad60fb81196dab9a1f2d283b6470bf1fac6e5cd43ba002d
pkgname = check50
depends = lib50
- depends = python
- depends = python-bs4
+ depends = python-beautifulsoup4
depends = python-pyaml
- depends = submit50
-
+ depends = python-jinja
diff --git a/PKGBUILD b/PKGBUILD
index 89cddd2c9fc0..03420e431fd7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,20 +4,20 @@
pkgname=check50
_module='check50' # PyPI specific
-pkgver=3.1.2
+pkgver=3.3.3
pkgrel=1
pkgdesc="This is check50, with which you can check solutions to problems for CS50."
arch=('any')
url="https://github.com/cs50/check50"
license=('GPL')
groups=('cs50');
-depends=('lib50' 'python' 'python-bs4' 'python-pyaml' 'submit50')
+depends=('lib50' 'python-beautifulsoup4' 'python-pyaml' 'python-jinja')
makedepends=('python-setuptools')
source=(
"https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz"
)
sha256sums=(
- 'e34d39c9a230e80dc2105737f64f9d93bcecb150e184fc70bff2ac849c5f9bd4'
+ '61995f43be54d6c90ad60fb81196dab9a1f2d283b6470bf1fac6e5cd43ba002d'
)
build() {