summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Feuls2017-04-23 19:30:44 +0200
committerCarsten Feuls2017-04-23 19:30:44 +0200
commitbd7151f73b22c5b5253ba1d61818f44a1824261e (patch)
tree74f888dce1ce70ea04f18ee53fe0192ac1e1614c
downloadaur-bd7151f73b22c5b5253ba1d61818f44a1824261e.tar.gz
Initial Commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD31
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b5f13634f1fc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sun Apr 23 17:27:21 UTC 2017
+pkgbase = check_bareos-git
+ pkgdesc = Icinga Plugin to check Bareos Backup Director databases
+ pkgver = r25.85f183b
+ pkgrel = 1
+ url = https://github.com/widhalmt/check_bareos
+ arch = any
+ license = GPLv3
+ depends = python
+ depends = python-psycopg2
+ depends = mysql-python
+ optdepends = postgresql
+ optdepends = mariadb
+ source = git+https://github.com/widhalmt/check_bareos.git
+ sha512sums = SKIP
+
+pkgname = check_bareos-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4d4e1315be47
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Carsten Feuls <archlinux dot carstenfeuls dot de>
+
+pkgname=check_bareos-git
+_pkgname=check_bareos
+pkgver=r25.85f183b
+pkgrel=1
+pkgdesc="Icinga Plugin to check Bareos Backup Director databases"
+arch=('any')
+url="https://github.com/widhalmt/check_bareos"
+license=('GPLv3')
+depends=('python' 'python-psycopg2' 'mysql-python')
+optdepends=('postgresql' 'mariadb')
+source=("git+https://github.com/widhalmt/check_bareos.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd ${srcdir}/${_pkgname}
+ echo "r$(git rev-list --count HEAD).$(git describe --always)"
+}
+
+package() {
+ cd ${srcdir}/${_pkgname}
+ mkdir -p "${pkgdir}/usr/lib/monitoring-plugins"
+ cp check_bareos.py "${pkgdir}/usr/lib/monitoring-plugins/"
+ chmod o+rx "${pkgdir}/usr/lib/monitoring-plugins/check_bareos.py"
+ mkdir -p "${pkgdir}/usr/share/icinga2/include/plugins-contrib.d/"
+ cp "contrib/icinga2-commands.conf" "${pkgdir}/usr/share/icinga2/include/plugins-contrib.d/bareos.conf"
+ mkdir -p ${pkgdir}//usr/share/licenses/${pkgname}
+ cp LICENSE "${pkgdir}//usr/share/licenses/${pkgname}/"
+}
+