summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormreichardt2016-06-03 10:49:12 +0200
committermreichardt2016-06-03 10:49:12 +0200
commit9da5d2245747a7e4c8c27116a84ec9e40ccce3d9 (patch)
treee387d8ce76ecba2f4a9da5f61e2bac385f13d3fc
downloadaur-9da5d2245747a7e4c8c27116a84ec9e40ccce3d9.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
-rw-r--r--check_mk-agent.install7
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7df99320fd4a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = check_mk-agent
+ pkgdesc = Agent to retrieve Information from Client in a Check_MK environment
+ pkgver = 1.2.8p3
+ pkgrel = 1
+ url = https://mathias-kettner.de
+ install = check_mk-agent.install
+ arch = any
+ license = GPLv2
+ depends = xinetd
+ source = https://mathias-kettner.de/download/check_mk-1.2.8p3.tar.gz
+ md5sums = SKIP
+
+pkgname = check_mk-agent
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..03cfd2049535
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Milian Reichardt <mreichardt95@gmail.com>
+
+pkgname=check_mk-agent
+pkgver=1.2.8p3
+pkgrel=1
+pkgdesc="Agent to retrieve Information from Client in a Check_MK environment"
+arch=(any)
+url="https://mathias-kettner.de"
+license=('GPLv2')
+install=check_mk-agent.install
+depends=('xinetd')
+source=("https://mathias-kettner.de/download/check_mk-$pkgver.tar.gz")
+md5sums=('SKIP')
+build() {
+ tar xfvz "$srcdir/check_mk-$pkgver/agents.tar.gz"
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/bin/"
+ mkdir -p "$pkgdir/etc/xinetd.d/"
+ cp -r "$srcdir/check_mk_agent.linux" "$pkgdir/usr/bin/check_mk_agent"
+ cp -r "$srcdir/cfg_examples/xinetd.conf" "$pkgdir/etc/xinetd.d/check_mk"
+}
diff --git a/check_mk-agent.install b/check_mk-agent.install
new file mode 100644
index 000000000000..2ceec65afe02
--- /dev/null
+++ b/check_mk-agent.install
@@ -0,0 +1,7 @@
+post_install() {
+ systemctl restart xinetd.service
+}
+post_upgrade() {
+ systemctl restart xinetd.service
+}
+