summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Parrish2022-08-02 16:10:46 -0400
committerDavid Parrish2022-08-02 16:10:46 -0400
commit862438af9776a695e9abe5573db38f0562642fe9 (patch)
treeed47372ee2c5fdc7051dca638186585d0fe1467a
parentf6cb7eb433962eccbeedee40310b1cd74ef41ac1 (diff)
downloadaur-862438af9776a695e9abe5573db38f0562642fe9.tar.gz
Switch to a python3 fork which is better maintained
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD14
2 files changed, 8 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 758961a96ae4..b884b10d917b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = check_smartmon-git
pkgdesc = Nagios-Plugin that uses smartmontools (http://smartmontools.sourceforge.net/) to check disk health status and temperature.
- pkgver = r31.07b14b8
+ pkgver = r43.66ec3f3
pkgrel = 1
- url = https://github.com/nihlaeth/Nagios_check_smartmon
+ url = https://github.com/driehuis/Nagios_check_smartmon
arch = any
license = GPL2
makedepends = git
- depends = python2-psutil
+ depends = python-psutil
depends = smartmontools
- source = check_smartmon-git::git+https://github.com/nihlaeth/Nagios_check_smartmon.git
+ source = check_smartmon-git::git+https://github.com/driehuis/Nagios_check_smartmon.git
sha256sums = SKIP
pkgname = check_smartmon-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 5eae52ae029d..97afd8d569f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: David Parrish <daveparrish@tutanota.com>
pkgname=check_smartmon-git
-pkgver=r31.07b14b8
+pkgver=r43.66ec3f3
pkgrel=1
pkgdesc="Nagios-Plugin that uses smartmontools (http://smartmontools.sourceforge.net/) to check disk health status and temperature."
arch=('any')
-url="https://github.com/nihlaeth/Nagios_check_smartmon"
+url="https://github.com/driehuis/Nagios_check_smartmon"
license=('GPL2')
-depends=('python2-psutil' 'smartmontools')
+depends=('python-psutil' 'smartmontools')
makedepends=('git')
-source=("${pkgname}::git+https://github.com/nihlaeth/Nagios_check_smartmon.git")
+source=("${pkgname}::git+https://github.com/driehuis/Nagios_check_smartmon.git")
sha256sums=("SKIP")
pkgver() {
@@ -17,12 +17,6 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- cd "$pkgname" || exit 1
- # Fixing Python version
- find . -type f -print0 | xargs -0 sed -i 's#/usr/bin/python$#/usr/bin/python2#g'
-}
-
package() {
# Install License
install -Dm644 "$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"