summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Parrish2016-09-24 14:53:36 -0400
committerDavid Parrish2016-09-24 14:53:36 -0400
commit4380c93ac77f773c7a2fe77408925dda785dc242 (patch)
tree1a27b65cc4a911ed35ed843894b400480a230b4f
downloadaur-4380c93ac77f773c7a2fe77408925dda785dc242.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD35
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1ede722cd11c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Sat Sep 24 18:52:45 UTC 2016
+pkgbase = check_zfs-git
+ pkgdesc = Nagios-Plugin to check the status of a ZFS pool.
+ pkgver = r13.20eef86
+ pkgrel = 1
+ url = https://github.com/zlacelle/nagios_check_zfs_linux
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = python
+ source = check_zfs-git::git+https://github.com/zlacelle/nagios_check_zfs_linux.git
+ sha256sums = SKIP
+
+pkgname = check_zfs-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f436e87af012
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: David Parrish <daveparrish@tutanota.com>
+
+pkgname=check_zfs-git
+pkgver=r13.20eef86
+pkgrel=1
+pkgdesc="Nagios-Plugin to check the status of a ZFS pool."
+arch=('i686' 'x86_64')
+url="https://github.com/zlacelle/nagios_check_zfs_linux"
+license=('GPL3')
+depends=('python')
+source=("${pkgname}::git+https://github.com/zlacelle/nagios_check_zfs_linux.git")
+sha256sums=("SKIP")
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$pkgname"
+ msg 'Fixing Python version...'
+ find . -type f -print0 | xargs -0 sed -i 's#/usr/bin/python$#/usr/bin/python2#g'
+}
+
+package() {
+ # Install License
+ install -Dm644 "$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ # Put code files into '/usr/share'
+ install -Dm755 "$pkgname/check_zfs.py" "$pkgdir/usr/share/check_zfs-git/check_zfs.py"
+
+ # Install binary
+ install -d "${pkgdir}/usr/bin"
+ ln -s "/usr/share/check_zfs-git/check_zfs.py" "${pkgdir}/usr/bin/check_zfs"
+}