summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJuliette Monsel2018-07-13 17:25:11 +0200
committerJuliette Monsel2018-07-13 17:25:11 +0200
commit361bb6c4e78a144d225106fdbe4a0a272e9d41ea (patch)
tree1538e7c97c648d6314d1687e843ea359952e2073
parent3e75d749fa0ad603f86f0624530966176ef41459 (diff)
downloadaur-361bb6c4e78a144d225106fdbe4a0a272e9d41ea.tar.gz
Improve PKGBUILD
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9a2ef4570a84..d5c9742f4eb3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = checkmails
pkgdesc = System tray unread mail checker using IMAP protocol
pkgver = 1.2.1
- pkgrel = 1
+ pkgrel = 2
url = https://sourceforge.net/projects/checkmails
changelog = changelog
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index d26ffbfed536..3f6d4c4a50bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Juliette Monsel <j_4321 at protonmail dot com>
pkgname=checkmails
pkgver=1.2.1
-pkgrel=1
+pkgrel=2
pkgdesc="System tray unread mail checker using IMAP protocol"
arch=('any')
url="https://sourceforge.net/projects/checkmails"
@@ -13,11 +13,16 @@ optdepends=('tktray: GUI toolkit for the system tray icon (at least one must be
'python-pyqt5: GUI toolkit for the system tray icon (at least one must be installed)',
'python-pyqt4: GUI toolkit for the system tray icon (at least one must be installed)',
'python-pyside: GUI toolkit for the system tray icon (at least one must be installed)')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/j4321/CheckMails/archive/v${pkgver}.tar.gz")
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/j4321/CheckMails/archive/v$pkgver.tar.gz")
sha512sums=('0ab34ba8db7581da848573b18769b15256cf20fc4a159a4871f6d3ae1d4af8b09bf1c555f7b748813ac2f147cf864bda1c20ebeb67739d79533ff773001c0757')
changelog=changelog
+build() {
+ cd "$srcdir/CheckMails-$pkgver"
+ python setup.py build
+}
+
package() {
- cd "$srcdir/CheckMails-${pkgver}"
- python3 setup.py install --root="$pkgdir/" --prefix=/usr --optimize=1;
+ cd "$srcdir/CheckMails-$pkgver"
+ python setup.py install --root="$pkgdir/" --prefix=/usr --optimize=1 --skip-build
}