summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaroslav Lichtblau2014-11-28 20:17:14 +0100
committerJaroslav Lichtblau2014-11-28 20:17:14 +0100
commit9a23663541fd674a36c6b13419e5217b8f00fea8 (patch)
tree2b58ebfae179a1a0acc065042516c128c336c3eb
downloadaur-9a23663541fd674a36c6b13419e5217b8f00fea8.tar.gz
Initial PKGBUILD status as of 28.11.2014
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD30
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..556df2418df6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = checkpassword
+ pkgdesc = A simple, uniform password-checking interface to all root applications.
+ pkgver = 0.90
+ pkgrel = 1
+ url = http://cr.yp.to/checkpwd.html
+ arch = i686
+ arch = x86_64
+ license = custom: as-is
+ depends = glibc
+ source = http://cr.yp.to/checkpwd/checkpassword-0.90.tar.gz
+ md5sums = e75842e908f96571ae56c3da499ba1fc
+
+pkgname = checkpassword
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c3de15066f29
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# $Id: PKGBUILD 4654 2008-07-08 08:58:05Z ronald $
+# Maintainer: eric <eric@archlinux.org>
+# Contributor: Manolis Tzanidakis
+#
+
+pkgname=checkpassword
+pkgver=0.90
+pkgrel=1
+pkgdesc="A simple, uniform password-checking interface to all root applications."
+arch=('i686' 'x86_64')
+url="http://cr.yp.to/checkpwd.html"
+depends=('glibc')
+source=(http://cr.yp.to/checkpwd/$pkgname-$pkgver.tar.gz)
+license=('custom: as-is')
+md5sums=('e75842e908f96571ae56c3da499ba1fc')
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+
+ # fix errno.h in glibc-2.3.x
+ /bin/sed -i "s:extern int errno;:#include <errno.h>:" error.h
+ /bin/echo "gcc ${CFLAGS}" > conf-cc
+ /usr/bin/make || return 1
+ /bin/install -D -m 755 checkpassword $startdir/pkg/usr/bin/checkpassword
+
+ # install copyright notice
+ install -Dm644 $srcdir/$pkgname-$pkgver/README \
+ $pkgdir/usr/share/licenses/$pkgname/README
+}
+# vim: ts=2: ft=sh