summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2020-07-19 11:32:22 +0200
committerNicolas Iooss2020-07-19 11:32:22 +0200
commitb175bde150922374fc0bed3956e5fd0c824735b5 (patch)
tree257a2fe8df1b72739d00e716f341b26e2e4218a5
parent4a5f267a432bbfd5c6679bc8ef976a5b406623b3 (diff)
downloadaur-b175bde150922374fc0bed3956e5fd0c824735b5.tar.gz
checkpolicy 3.1-1 update
-rw-r--r--.SRCINFO16
-rw-r--r--0001-checkpolicy-remove-unused-te_assertions.patch42
-rw-r--r--PKGBUILD22
3 files changed, 13 insertions, 67 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2cc4f65ac71b..4286c14a64c9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,17 @@
pkgbase = checkpolicy
pkgdesc = SELinux policy compiler
- pkgver = 3.0
- pkgrel = 2
- url = http://userspace.selinuxproject.org
+ pkgver = 3.1
+ pkgrel = 1
+ url = https://github.com/SELinuxProject/selinux
arch = i686
arch = x86_64
groups = selinux
license = GPL2
- makedepends = libsepol>=3.0
- provides = selinux-usr-checkpolicy=3.0-2
+ makedepends = libsepol>=3.1
+ provides = selinux-usr-checkpolicy=3.1-1
conflicts = selinux-usr-checkpolicy
- source = https://github.com/SELinuxProject/selinux/releases/download/20191204/checkpolicy-3.0.tar.gz
- source = 0001-checkpolicy-remove-unused-te_assertions.patch
- sha256sums = c88c719a141dd5c1202d49c378c7f063349d630522d5e04dc6e0c53da81aa4f8
- sha256sums = 8ee8d4e01e7441fe8bee97c41dabc37ed707f55e65ad6d415382590cbc0597e2
+ source = https://github.com/SELinuxProject/selinux/releases/download/20200710/checkpolicy-3.1.tar.gz
+ sha256sums = dfc7707070520c93b14fbbdfdbe081364d806bf28e3e79e10318c2594c77bbb2
pkgname = checkpolicy
diff --git a/0001-checkpolicy-remove-unused-te_assertions.patch b/0001-checkpolicy-remove-unused-te_assertions.patch
deleted file mode 100644
index deb6e76f2d39..000000000000
--- a/0001-checkpolicy-remove-unused-te_assertions.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From 4d330d0d3155211f119b3082f728ae42dcc01e96 Mon Sep 17 00:00:00 2001
-From: Ondrej Mosnacek <omosnace@redhat.com>
-Date: Thu, 23 Jan 2020 13:57:15 +0100
-Subject: [PATCH] checkpolicy: remove unused te_assertions
-
-This variable is declared in a header file, but never defined or used.
-The te_assert structure definition is only used in this declaration, so
-remove both.
-
-Signed-off-by: Ondrej Mosnacek <omosnace@redhat.com>
----
- checkpolicy/checkpolicy.h | 14 --------------
- 1 file changed, 14 deletions(-)
-
-diff --git a/checkpolicy/checkpolicy.h b/checkpolicy/checkpolicy.h
-index 3868f1fa023b..f127687e72a6 100644
---- a/checkpolicy/checkpolicy.h
-+++ b/checkpolicy/checkpolicy.h
-@@ -1,20 +1,6 @@
- #ifndef _CHECKPOLICY_H_
- #define _CHECKPOLICY_H_
-
--#include <sepol/policydb/ebitmap.h>
--
--typedef struct te_assert {
-- ebitmap_t stypes;
-- ebitmap_t ttypes;
-- ebitmap_t tclasses;
-- int self;
-- sepol_access_vector_t *avp;
-- unsigned long line;
-- struct te_assert *next;
--} te_assert_t;
--
--te_assert_t *te_assertions;
--
- extern unsigned int policyvers;
-
- #endif
---
-2.27.0
-
diff --git a/PKGBUILD b/PKGBUILD
index 434ea2c6dd7c..530f42ca83e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,28 +7,18 @@
# If you want to help keep it up to date, please open a Pull Request there.
pkgname=checkpolicy
-pkgver=3.0
-pkgrel=2
+pkgver=3.1
+pkgrel=1
pkgdesc="SELinux policy compiler"
arch=('i686' 'x86_64')
-url='http://userspace.selinuxproject.org'
+url='https://github.com/SELinuxProject/selinux'
license=('GPL2')
groups=('selinux')
-makedepends=('libsepol>=3.0')
+makedepends=('libsepol>=3.1')
conflicts=("selinux-usr-${pkgname}")
provides=("selinux-usr-${pkgname}=${pkgver}-${pkgrel}")
-source=("https://github.com/SELinuxProject/selinux/releases/download/20191204/${pkgname}-${pkgver}.tar.gz"
- '0001-checkpolicy-remove-unused-te_assertions.patch')
-sha256sums=('c88c719a141dd5c1202d49c378c7f063349d630522d5e04dc6e0c53da81aa4f8'
- '8ee8d4e01e7441fe8bee97c41dabc37ed707f55e65ad6d415382590cbc0597e2')
-
-prepare() {
- cd "${pkgname}-${pkgver}"
-
- # Backport commit 4d330d0d3155 ("checkpolicy: remove unused te_assertions")
- # https://github.com/SELinuxProject/selinux/commit/4d330d0d3155211f119b3082f728ae42dcc01e96
- patch -Np2 -i ../0001-checkpolicy-remove-unused-te_assertions.patch
-}
+source=("https://github.com/SELinuxProject/selinux/releases/download/20200710/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('dfc7707070520c93b14fbbdfdbe081364d806bf28e3e79e10318c2594c77bbb2')
build() {
cd "${pkgname}-${pkgver}"