summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2017-08-11 14:07:58 +0200
committerNicolas Iooss2017-08-11 14:07:58 +0200
commitf590be09c3f925f49f6079ece927c3595f0b6c54 (patch)
treebdb699e9399a097e8f1a7a32638933d5e796295c
parentddb71c73ac72dcde7b400caea4240e43a64298a1 (diff)
downloadaur-f590be09c3f925f49f6079ece927c3595f0b6c54.tar.gz
checkpolicy 2.7-1 update
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD15
2 files changed, 13 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f4caff259697..83bde03186d8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,17 @@
pkgbase = checkpolicy
pkgdesc = SELinux policy compiler
- pkgver = 2.6
+ pkgver = 2.7
pkgrel = 1
url = http://userspace.selinuxproject.org
arch = i686
arch = x86_64
groups = selinux
- license = GPL
- depends = libsepol>=2.5
- depends = libselinux>=2.5
- provides = selinux-usr-checkpolicy=2.6-1
+ license = GPL2
+ makedepends = libsepol>=2.7
+ provides = selinux-usr-checkpolicy=2.7-1
conflicts = selinux-usr-checkpolicy
- options = !emptydirs
- source = https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20161014/checkpolicy-2.6.tar.gz
- sha256sums = 0bebd18688ca8027b1b3b4ff1532c0626f1fe49883ae6cb74d9d385940e74157
+ source = https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20170804/checkpolicy-2.7.tar.gz
+ sha256sums = 5413479f1dcde866c19896b4dbfec315d822aa431606e1d03c944408984c3201
pkgname = checkpolicy
diff --git a/PKGBUILD b/PKGBUILD
index 02ae899c29a7..92db21940d85 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,28 +4,27 @@
# Contributor: Sergej Pupykin (pupykin <dot> s+arch <at> gmail <dot> com)
pkgname=checkpolicy
-pkgver=2.6
+pkgver=2.7
pkgrel=1
pkgdesc="SELinux policy compiler"
arch=('i686' 'x86_64')
url='http://userspace.selinuxproject.org'
-license=('GPL')
+license=('GPL2')
groups=('selinux')
-depends=('libsepol>=2.5' 'libselinux>=2.5')
+makedepends=('libsepol>=2.7')
conflicts=("selinux-usr-${pkgname}")
provides=("selinux-usr-${pkgname}=${pkgver}-${pkgrel}")
-options=(!emptydirs)
-source=("https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20161014/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('0bebd18688ca8027b1b3b4ff1532c0626f1fe49883ae6cb74d9d385940e74157')
+source=("https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20170804/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('5413479f1dcde866c19896b4dbfec315d822aa431606e1d03c944408984c3201')
build() {
cd "${pkgname}-${pkgver}"
make
}
-package(){
+package() {
cd "${pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}" install
+ make DESTDIR="${pkgdir}" LIBSEPOLA=/usr/lib/libsepol.a install
install -m 0755 test/dismod "${pkgdir}"/usr/bin/sedismod
install -m 0755 test/dispol "${pkgdir}"/usr/bin/sedispol
}