summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcfair2018-12-19 10:52:35 -0700
committercfair2018-12-19 10:52:35 -0700
commite5244f1330f621fa6f679171d5d275283c5f57ee (patch)
tree589ef6099c744b9332a0d10e832a07309068b911
downloadaur-e5244f1330f621fa6f679171d5d275283c5f57ee.tar.gz
Changes to be committed:
new file: .SRCINFO new file: PKGBUILD
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD22
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d18ffe86c410
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = checkpwn
+ pkgdesc = Checks whether the account or the password is on the list of compromised accounts.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/chrisfair/checkpwn/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = git
+ depends = openssl
+ source = https://github.com/chrisfair/checkpwn/releases/download/v1.0.0/checkpwn.tar.gz
+ sha1sums = e964fa35aad39a9dcf54df31ed6ec80bdffab3fc
+
+pkgname = checkpwn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..64b9fc26e7c6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Christopher Fair <christopherpfair@comcast.net>
+pkgname=checkpwn
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Checks whether the account or the password is on the list of compromised accounts."
+arch=('i686' 'x86_64')
+url="https://github.com/chrisfair/checkpwn/"
+license=('MIT')
+depends=('git' 'openssl')
+makedepends=('git')
+source=("https://github.com/chrisfair/checkpwn/releases/download/v${pkgver}/checkpwn.tar.gz")
+sha1sums=('e964fa35aad39a9dcf54df31ed6ec80bdffab3fc')
+
+package() {
+ cd "${srcdir}"
+
+ # app install
+ mkdir -p "${pkgdir}/usr/bin"
+ install "${srcdir}/${pkgname}" "${pkgdir}/usr/bin"
+}
+
+