summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkaptoxic2016-05-02 01:43:29 -0400
committerkaptoxic2016-05-02 01:43:29 -0400
commit09a4bdbb64b5ea6dd75163aa17571add8085d7f9 (patch)
tree0f6dd03e437b13b93c12f67132bd96b90487e185
downloadaur-09a4bdbb64b5ea6dd75163aa17571add8085d7f9.tar.gz
Revive original package
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD28
-rw-r--r--checkstyle3
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3dd10425bc5d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Mon May 2 05:43:23 UTC 2016
+pkgbase = checkstyle
+ pkgdesc = Checkstyle is a development tool to help programmers write Java code that adheres to a coding standard
+ pkgver = 5.9
+ pkgrel = 1
+ url = http://checkstyle.sourceforge.net
+ arch = i686
+ arch = x86_64
+ license = LGPL2
+ depends = java-environment
+ source = http://downloads.sourceforge.net/project/checkstyle/checkstyle/5.9/checkstyle-5.9-bin.tar.gz
+ source = checkstyle
+ md5sums = 032e8653dcee6d5370d7f84c87ac2548
+ md5sums = 8326c63991962d738fa9c55d0dd8d64d
+
+pkgname = checkstyle
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eaf8de59fdd2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Jaime Gil de Sagredo <jaimegildesagredo@gmail.com
+
+pkgname='checkstyle'
+pkgver='5.9'
+pkgrel=1
+pkgdesc='Checkstyle is a development tool to help programmers write Java code that adheres to a coding standard'
+depends=('java-environment')
+arch=('i686' 'x86_64')
+license=('LGPL2')
+url='http://checkstyle.sourceforge.net'
+source=(
+ "http://downloads.sourceforge.net/project/checkstyle/checkstyle/${pkgver}/${pkgname}-${pkgver}-bin.tar.gz"
+ 'checkstyle')
+md5sums=(
+ '032e8653dcee6d5370d7f84c87ac2548'
+ '8326c63991962d738fa9c55d0dd8d64d')
+
+function package() {
+ local destdir="${pkgdir}/opt/${pkgname}"
+ local bindir="${pkgdir}/usr/bin"
+
+ mkdir -pv ${destdir}
+ mkdir -pv ${bindir}
+
+ cp -r "${srcdir}/${pkgname}-${pkgver}"/* ${destdir}
+
+ install -m755 "${srcdir}/${pkgname}" ${bindir}
+}
diff --git a/checkstyle b/checkstyle
new file mode 100644
index 000000000000..d94acebc94ea
--- /dev/null
+++ b/checkstyle
@@ -0,0 +1,3 @@
+#!/bin/bash
+
+java -jar /opt/checkstyle/checkstyle-5.9-all.jar $@