summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcin Wieczorek2018-01-02 01:36:25 +0100
committerMarcin Wieczorek2018-01-02 01:36:25 +0100
commit8313f8a2a1c5e081f6f0c5e59071c99d51511809 (patch)
tree8944c1ff66dbd637a3686ae111570d5346fbb67f
parentbeefb1953656723d294ded7d95ab0223e3ff8c73 (diff)
downloadaur-8313f8a2a1c5e081f6f0c5e59071c99d51511809.tar.gz
Version '8.5'
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD20
2 files changed, 17 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e92561ae6e87..c2d8a266d7e3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,3 @@
-# Generated by mksrcinfo v8
-# Wed Dec 6 19:44:24 UTC 2017
pkgbase = checkstyle
pkgdesc = A tool to help programmers write Java code that adheres to a coding standard
pkgver = 8.5
@@ -7,11 +5,13 @@ pkgbase = checkstyle
url = http://checkstyle.sourceforge.net
arch = any
license = LGPL2.1
+ makedepends = maven
+ makedepends = java-environment>=8
depends = java-runtime>=8
- source = https://sourceforge.net/projects/checkstyle/files/checkstyle/8.5/checkstyle-8.5-bin.tar.gz/download
+ source = https://github.com/checkstyle/checkstyle/archive/checkstyle-8.5.tar.gz
source = checkstyle
- md5sums = 5ace016b0fd22b6cd86b06119f648815
- md5sums = eb71b85acb81e0d3c5f0809fe93641dc
+ sha256sums = 52e2646c36e3b2226adda575129b679eb5824dbf24c0c3a11e3617e764a4ad2f
+ sha256sums = 5bf5f7e688aec23fce2a507384c595ac44339ace5bb9624fc8be61e036688234
pkgname = checkstyle
diff --git a/PKGBUILD b/PKGBUILD
index 7bb4e260551b..34d26c76f48a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,20 +9,24 @@ pkgdesc='A tool to help programmers write Java code that adheres to a coding sta
arch=('any')
license=('LGPL2.1')
depends=('java-runtime>=8')
-#makedepends=('maven' 'java-environment>=8')
+makedepends=('maven' 'java-environment>=8')
url='http://checkstyle.sourceforge.net'
-source=(
- "https://sourceforge.net/projects/checkstyle/files/checkstyle/${pkgver}/${pkgname}-${pkgver}-bin.tar.gz/download"
- 'checkstyle')
-md5sums=('5ace016b0fd22b6cd86b06119f648815'
- 'eb71b85acb81e0d3c5f0809fe93641dc')
+source=("https://github.com/checkstyle/checkstyle/archive/checkstyle-${pkgver}.tar.gz"
+ 'checkstyle')
+sha256sums=('52e2646c36e3b2226adda575129b679eb5824dbf24c0c3a11e3617e764a4ad2f'
+ '5bf5f7e688aec23fce2a507384c595ac44339ace5bb9624fc8be61e036688234')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgname}-${pkgver}/"
+ mvn -Passembly clean package
+}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}/"
+ cd "${srcdir}/${pkgname}-${pkgname}-${pkgver}/"
mkdir -p "${pkgdir}/usr/share/java/${pkgname}/"
mkdir -p "${pkgdir}/usr/bin/"
install -D -m755 "${srcdir}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
- install -D -m644 "${srcdir}/${pkgname}-${pkgver}/${pkgname}-${pkgver}-all.jar" "${pkgdir}/usr/share/java/${pkgname}/${pkgname}.jar"
+ install -D -m644 "target/${pkgname}-${pkgver}-all.jar" "${pkgdir}/usr/share/java/${pkgname}/${pkgname}.jar"
mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -D -m644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}