summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcin Wieczorek2016-09-22 23:59:39 +0200
committerMarcin Wieczorek2016-09-22 23:59:39 +0200
commitab6eba95aa0b25768c8c6db2f0b58115637862b2 (patch)
treee2dc05c5b7aa51685e278045fcd86c3f33c42208
parent9dec9c2e2f3db2c8ca865cc0dfce815c0a61c77f (diff)
downloadaur-ab6eba95aa0b25768c8c6db2f0b58115637862b2.tar.gz
Version 7.1.1
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD47
-rw-r--r--checkstyle2
4 files changed, 39 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3277c491c5c6..77711901c66e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
-# Generated by mksrcinfo v8
-# Sun Aug 14 00:38:47 UTC 2016
pkgbase = checkstyle
pkgdesc = A tool to help programmers write Java code that adheres to a coding standard
- pkgver = 6.18
+ pkgver = 7.1.1
pkgrel = 1
url = http://checkstyle.sourceforge.net
arch = i686
arch = x86_64
- license = LGPL2
- depends = java-environment
- source = https://sourceforge.net/projects/checkstyle/files/checkstyle/6.18/checkstyle-6.18-bin.tar.gz/download
+ license = LGPL2.1
+ makedepends = maven
+ makedepends = java-environment>=8
+ depends = java-runtime>=8
+ source = http://checkstyle.sourceforge.net/archive/checkstyle-7.1.1.tar.gz
source = checkstyle
- md5sums = dd3456e70fb91f7d77fb4666e89969e0
- md5sums = 2059277aee1e877eab1d127a0110d1c3
+ sha256sums = bff636d85abd5d3d17d99a9bbc2adacdf8ff9afe484a86b73e1d759053763a26
+ sha256sums = 6ac8fd25eb47e096c9e709dbe92cefbd85f0639433874e9b67abfd17beb31daf
pkgname = checkstyle
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..243ddebc03ba
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+src/
+pkg/
+*.tar.gz
+*.pkg.tar.xz
+*.log
diff --git a/PKGBUILD b/PKGBUILD
index 05027518cbce..276ba769ca88 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,31 @@
-# Contributor: Jaime Gil de Sagredo <jaimegildesagredo@gmail.com
-# Maintainer: kaptoxic@yahoo.com
+# Maintainer: kaptoxic <kaptoxic@yahoo.com>
+# Maintainer: Marcin (CTRL) Wieczorek <marcin@marcin.co>
+# Contributor: Jaime Gil de Sagredo <jaimegildesagredo@gmail.com>
-pkgname='checkstyle'
-pkgver='6.18'
+pkgname=checkstyle
+pkgver=7.1.1
pkgrel=1
pkgdesc='A tool to help programmers write Java code that adheres to a coding standard'
-depends=('java-environment')
-arch=('i686' 'x86_64')
-license=('LGPL2')
-url='http://checkstyle.sourceforge.net'
-source=(
- "https://sourceforge.net/projects/checkstyle/files/checkstyle/${pkgver}/${pkgname}-${pkgver}-bin.tar.gz/download"
- 'checkstyle')
-md5sums=('dd3456e70fb91f7d77fb4666e89969e0'
- '2059277aee1e877eab1d127a0110d1c3')
+arch=('any')
+license=('LGPL2.1')
+depends=('java-runtime>=8')
+makedepends=('maven' 'java-environment>=8')
+url='https://github.com/checkstyle/checkstyle'
+source=("${url}/archive/checkstyle-${pkgver}.tar.gz"
+ 'checkstyle')
+sha256sums=('bff636d85abd5d3d17d99a9bbc2adacdf8ff9afe484a86b73e1d759053763a26'
+ 'fd16398cd50d9e066c0fcd496c50132ba054706a2bc2e8260f1111f78324edc7')
-function package() {
- local destdir="${pkgdir}/opt/${pkgname}"
- local bindir="${pkgdir}/usr/bin"
-
- mkdir -pv ${destdir}
- mkdir -pv ${bindir}
-
- cp -r "${srcdir}/${pkgname}-${pkgver}"/* ${destdir}
+build() {
+ cd "${srcdir}/${pkgname}-${pkgname}-${pkgver}/"
+ mvn -Passembly clean package
+}
- install -m755 "${srcdir}/${pkgname}" ${bindir}
+package() {
+ cd "${srcdir}/${pkgname}-${pkgname}-${pkgver}/"
+ mkdir -p "${pkgdir}/usr/share/${pkgname}/"
+ mkdir -p "${pkgdir}/usr/bin/"
+ install -D -m755 "${srcdir}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -D -m644 "${srcdir}/${pkgname}-${pkgname}-${pkgver}/target/${pkgname}-${pkgver}-all.jar" "${pkgdir}/usr/share/${pkgname}/${pkgname}.jar"
+ install -D -m644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
diff --git a/checkstyle b/checkstyle
index 3b169cb17e37..2b326d635fa0 100644
--- a/checkstyle
+++ b/checkstyle
@@ -1,3 +1,3 @@
#!/bin/bash
-java -jar /opt/checkstyle/checkstyle-6.18-all.jar $@
+java -jar /usr/share/checkstyle/checkstyle.jar $@