summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkaptoxic2017-09-21 16:14:22 -0400
committerkaptoxic2017-09-21 16:25:34 -0400
commit7707ab50db4f998d023c1c07c3527bcffd5ad864 (patch)
tree56825320ff66da7ceb24fa2acd30f0d0fc0a5ca6
downloadaur-7707ab50db4f998d023c1c07c3527bcffd5ad864.tar.gz
Start a new package
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD29
-rw-r--r--checkstyle3
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7c89a5ec2efa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Thu Sep 21 20:23:10 UTC 2017
+pkgbase = checkstyle-bin
+ pkgdesc = A tool for helping programmers write Java code that adheres to a coding standard
+ pkgver = 8.2
+ pkgrel = 1
+ url = http://checkstyle.sourceforge.net
+ arch = any
+ license = LGPL2.1
+ depends = java-runtime>=8
+ provides = checkstyle
+ conflicts = checkstyle
+ source = https://sourceforge.net/projects/checkstyle/files/checkstyle/8.2/checkstyle-8.2-bin.tar.gz/download
+ source = checkstyle
+ md5sums = 1a61a8dd39e8886fe59ec350686a033f
+ md5sums = 74f9c7a1d6ceaece01a0035158338849
+
+pkgname = checkstyle-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..837bd3ee88e9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: kaptoxic@yahoo.com
+# Contributor: Jaime Gil de Sagredo <jaimegildesagredo@gmail.com>
+
+_basename=checkstyle
+pkgname='checkstyle-bin'
+pkgver='8.2'
+pkgrel=1
+pkgdesc='A tool for helping programmers write Java code that adheres to a coding standard'
+arch=('any')
+license=('LGPL2.1')
+depends=('java-runtime>=8')
+#makedepends=('maven' 'java-environment>=8')
+conflicts=('checkstyle')
+provides=('checkstyle')
+url='http://checkstyle.sourceforge.net'
+source=(
+ "https://sourceforge.net/projects/checkstyle/files/checkstyle/${pkgver}/${_basename}-${pkgver}-bin.tar.gz/download"
+ 'checkstyle')
+md5sums=('1a61a8dd39e8886fe59ec350686a033f'
+ '74f9c7a1d6ceaece01a0035158338849')
+
+package() {
+ cd "${srcdir}/${_basename}-${pkgver}/"
+ mkdir -p "${pkgdir}/usr/share/java/${_basename}/"
+ mkdir -p "${pkgdir}/usr/bin/"
+ install -D -m755 "${srcdir}/${_basename}" "${pkgdir}/usr/bin/${_basename}"
+ install -D -m644 "${srcdir}/${_basename}-${pkgver}/${_basename}-${pkgver}-all.jar" "${pkgdir}/usr/share/java/${_basename}/${_basename}.jar"
+ install -D -m644 "LICENSE" "${pkgdir}/usr/share/licenses/${_basename}/LICENSE"
+}
diff --git a/checkstyle b/checkstyle
new file mode 100644
index 000000000000..2b326d635fa0
--- /dev/null
+++ b/checkstyle
@@ -0,0 +1,3 @@
+#!/bin/bash
+
+java -jar /usr/share/checkstyle/checkstyle.jar $@