summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDesmond Kabus2020-10-24 13:07:46 +0200
committerDesmond Kabus2020-10-24 13:07:46 +0200
commitb21118380661335ad55a0fc44a18cd6cf09213ac (patch)
treee2a857b0ba91cd5299d0eb4eacb0f7f143286520
downloadaur-b21118380661335ad55a0fc44a18cd6cf09213ac.tar.gz
Add PKGBUILD
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD25
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..406c7b3668a7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = checkupdates-systemd-git
+ pkgdesc = Systemd service and timer to check for updates using pacman-contrib
+ pkgver = r2.40c835e
+ pkgrel = 1
+ url = https://www.kabus.eu/git/checkupdates-systemd
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = make
+ depends = pacman-contrib
+ depends = systemd
+ provides = checkupdates-systemd
+ conflicts = checkupdates-systemd
+ source = checkupdates-systemd-git::git://www.kabus.eu/git/checkupdates-systemd
+ md5sums = SKIP
+
+pkgname = checkupdates-systemd-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f182a1226354
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Desmond Kabus <desmond.kabus@protonmail.com>
+
+pkgname=checkupdates-systemd-git
+pkgver=r2.40c835e
+pkgrel=1
+pkgdesc="Systemd service and timer to check for updates using pacman-contrib"
+arch=('any')
+url="https://www.kabus.eu/git/checkupdates-systemd"
+license=('GPL')
+depends=('pacman-contrib' 'systemd')
+makedepends=('git' 'make')
+provides=('checkupdates-systemd')
+conflicts=('checkupdates-systemd')
+source=('checkupdates-systemd-git::git://www.kabus.eu/git/checkupdates-systemd')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/${pkgname}"
+ make DESTDIR="$pkgdir/" install
+}