summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPellegrino Prevete2022-03-05 02:47:55 +0000
committerPellegrino Prevete2022-03-05 02:47:55 +0000
commit8dd6f33e254e96378126d749e51da9a7729d776a (patch)
tree39cfbec453a1230d02d24c544bbb0e960e4694c7
parent33c24bf34a53aae650df4a88b7996573da375e83 (diff)
downloadaur-8dd6f33e254e96378126d749e51da9a7729d776a.tar.gz
split cheese and libcheese
-rw-r--r--.SRCINFO38
-rw-r--r--PKGBUILD70
2 files changed, 81 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7f0c47bdf029..83ca80838667 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,9 @@
pkgbase = cheese-git
pkgdesc = Take photos and videos with your webcam, with fun graphical effects
- pkgver = 3.38.0+17+gf5553f7d
+ pkgver = 41.1+r5+gddee436d
pkgrel = 1
url = https://wiki.gnome.org/Apps/Cheese
- arch = any
- groups = gnome
+ arch = x86_64
license = GPL
checkdepends = xorg-server-xvfb
makedepends = gobject-introspection
@@ -26,10 +25,39 @@ pkgbase = cheese-git
depends = libgudev
depends = dconf
depends = gnome-video-effects
- provides = cheese
- conflicts = cheese
source = git+https://gitlab.gnome.org/GNOME/cheese.git
sha256sums = SKIP
pkgname = cheese-git
+ groups = gnome
+ depends = gtk3
+ depends = gstreamer
+ depends = gst-plugins-bad
+ depends = gst-plugins-base
+ depends = gst-plugins-good
+ depends = clutter-gst
+ depends = clutter-gtk
+ depends = libcanberra
+ depends = librsvg
+ depends = gnome-desktop
+ depends = libgudev
+ depends = dconf
+ depends = gnome-video-effects
+ depends = libcheese=41.1+r5+gddee436d-1
+ provides = cheese
+pkgname = libcheese-git
+ pkgdesc = Webcam widget for Clutter and GTK
+ depends = clutter
+ depends = clutter-gtk
+ depends = clutter-gst
+ depends = gdk-pixbuf2
+ depends = glib2
+ depends = gtk3
+ depends = libcanberra
+ depends = gstreamer
+ depends = gst-plugins-base-libs
+ depends = gst-plugins-bad-libs
+ provides = libcheese.so
+ provides = libcheese-gtk.so
+ provides = libcheese
diff --git a/PKGBUILD b/PKGBUILD
index 79baf407117e..917ac4206420 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,71 @@
-# Maintainer: Pellegrino Prevete <cGVsbGVncmlub3ByZXZldGVAZ21haWwuY29tCg== | base -d>
+# Maintainer: Pellegrino Prevete (tallero) <pellegrinoprevete@gmail.com>
+# Contributor: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
+# Contributor: Jan de Groot <jgc@archlinux.org>
-_pkgname=cheese
-pkgname=$_pkgname-git
-pkgver=3.38.0+17+gf5553f7d
+_pkgbase=cheese
+pkgbase=$_pkgbase-git
+pkgname=($_pkgbase-git lib$_pkgbase-git)
+pkgver=41.1+r5+gddee436d
pkgrel=1
pkgdesc="Take photos and videos with your webcam, with fun graphical effects"
url="https://wiki.gnome.org/Apps/Cheese"
-arch=(any)
+arch=(x86_64)
license=(GPL)
depends=(gtk3 gstreamer gst-plugins-bad gst-plugins-base gst-plugins-good clutter-gst clutter-gtk
libcanberra librsvg gnome-desktop libgudev dconf gnome-video-effects)
makedepends=(gobject-introspection vala git appstream-glib meson yelp-tools)
checkdepends=(xorg-server-xvfb)
-provides=($_pkgname)
-conflicts=($_pkgname)
-groups=(gnome)
-source=("git+https://gitlab.gnome.org/GNOME/cheese.git")
+source=("git+https://gitlab.gnome.org/GNOME/${_pkgbase}.git")
sha256sums=('SKIP')
pkgver() {
- cd $_pkgname
- git describe --tags | sed 's/-/+/g'
-}
-
-prepare() {
- cd $_pkgname
- #git tag -f 3.34.0 61ff7a2c26b618cb24be7ca3c050530671055602 # Fixup missing tag
+ cd "${_pkgbase}"
+ git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
}
build() {
- arch-meson $_pkgname build -D tests=true
- ninja -C build
+ arch-meson "${_pkgbase}" build -D tests=true
+ meson compile -C build
}
check() (
- glib-compile-schemas "${GSETTINGS_SCHEMA_DIR:=$PWD/$_pkgname/data}"
+ glib-compile-schemas "${GSETTINGS_SCHEMA_DIR:=$PWD/cheese/data}"
export GSETTINGS_SCHEMA_DIR
- xvfb-run meson test -C build --print-errorlogs
+ dbus-run-session xvfb-run -s '-nolisten local' \
+ meson test -C build --print-errorlogs
)
-package() {
- DESTDIR="$pkgdir" meson install -C build
+_pick() {
+ local p="$1" f d; shift
+ for f; do
+ d="$srcdir/$p/${f#$pkgdir/}"
+ mkdir -p "$(dirname "$d")"
+ mv "$f" "$d"
+ rmdir -p --ignore-fail-on-non-empty "$(dirname "$f")"
+ done
+}
+
+package_cheese-git() {
+ depends+=("libcheese=$pkgver-$pkgrel")
+ provides=("${_pkgbase}")
+ groups=(gnome)
+
+ meson install -C build --destdir "$pkgdir"
+
+ cd "$pkgdir"
+
+ _pick libs usr/include
+ _pick libs usr/lib/{girepository-1.0,libcheese*,pkgconfig}
+ _pick libs usr/share/{gir-1.0,glib-2.0/schemas,gtk-doc}
}
+
+package_libcheese-git() {
+ pkgdesc="Webcam widget for Clutter and GTK"
+ depends=(clutter clutter-gtk clutter-gst gdk-pixbuf2 glib2 gtk3 libcanberra
+ gstreamer gst-plugins-base-libs gst-plugins-bad-libs)
+ provides=(libcheese.so libcheese-gtk.so libcheese)
+ mv libs/* "$pkgdir"
+}
+
+# vim:set sw=2 et: