summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Vikstrom2016-11-10 02:03:18 +0100
committerSimon Vikstrom2016-11-10 02:03:39 +0100
commite542e12dfcc20ee5cd692ddffdb51bfe7be22d35 (patch)
treed2b5b7ed4e62f38afe0b146ca1ad66bf9f686644
downloadaur-e542e12dfcc20ee5cd692ddffdb51bfe7be22d35.tar.gz
Chef-client based on the chef-dk aur package
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..42204bd4d28a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Thu Nov 10 00:51:08 UTC 2016
+pkgbase = chef-client
+ pkgdesc = The Chef Client installation package includes everything you need to start converging your machines.
+ pkgver = 12.16.42
+ pkgrel = 1
+ url = https://downloads.chef.io/chef-client/
+ arch = x86_64
+ license = Apache
+ conflicts = chef
+ conflicts = chef-solo
+ source = https://packages.chef.io/stable/ubuntu/12.04/chef_12.16.42-1_amd64.deb
+ sha512sums = fc9adbb6dec79f432c37df2a5682627b72cd49ec207824a10edd985b3cb7bb6df987da0254c9f427cfcd2179048d0b4cc690fcb061dba7bd0b7e9c19585e10bd
+
+pkgname = chef-client
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2bfd45150582
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Simon Vikstrom <aur@devsn.se>
+
+pkgname=chef-client
+pkgver=12.16.42
+pkgrel=1
+_ubuntuver=raring
+_ubunturel=4
+pkgdesc="The Chef Client installation package includes everything you need to start converging your machines."
+arch=('x86_64')
+url="https://downloads.chef.io/chef-client/"
+license=('Apache')
+depends=()
+conflicts=( chef chef-solo )
+source=("https://packages.chef.io/stable/ubuntu/12.04/chef_${pkgver}-1_amd64.deb")
+sha512sums=('fc9adbb6dec79f432c37df2a5682627b72cd49ec207824a10edd985b3cb7bb6df987da0254c9f427cfcd2179048d0b4cc690fcb061dba7bd0b7e9c19585e10bd')
+
+package() {
+ cd "$srcdir"
+ bsdtar -xf data.tar.gz -C "$pkgdir"
+
+ # link executables
+ binaries="chef-apply chef-shell knife chef-client chef-solo ohai"
+
+ mkdir -p $pkgdir/usr/bin
+
+ for binary in $binaries; do
+ ln -s /opt/chefdk/bin/$binary $pkgdir/usr/bin/ || error_exit "Cannot link $binary to /usr/bin"
+ done
+ chown -Rh 0:0 $pkgdir
+ chmod 755 $pkgdir/opt
+}