summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarc A. Paradise2019-07-10 16:34:54 -0400
committerMarc A. Paradise2019-07-10 16:34:54 -0400
commitf45fcf2b16feb2bca7d557c144a1f87e15bb6f16 (patch)
tree37044d85e5ef04ca5bc1ddee56ca3d310869910d
parent8f7d3ce999bfa5b99d728ad522563c3051b25e2a (diff)
downloadaur-f45fcf2b16feb2bca7d557c144a1f87e15bb6f16.tar.gz
Add a Makefile and some git ignores
Signed-off-by: Marc A. Paradise <marc.paradise@gmail.com>
-rw-r--r--.gitignore4
-rw-r--r--Makefile18
2 files changed, 22 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f05a7493bf44
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg/
+/src/
+/*.deb
+/*.tar.xz
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..c81415812ee3
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,18 @@
+default: build
+
+build: namcap
+ makepkg
+ makepkg --printsrcinfo > .SRCINFO
+
+clean:
+ git clean -fd
+ rm -rf pkg src *.deb *.tar.xz
+
+namcap:
+ namcap PKGBUILD
+
+# too many failures we can't correct due to PKGBUILD design
+shellcheck:
+ shellcheck PKGBUILD
+
+vet: namcap shellcheck