summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTrevor Bramble2018-06-13 22:11:56 -0700
committerTrevor Bramble2018-06-13 22:11:56 -0700
commit5b10fbd7d3bcd57f271f678528e9863e3aa6b579 (patch)
tree05090de013a7480ffbbd8c8039d859f477f4dcfa
downloadaur-5b10fbd7d3bcd57f271f678528e9863e3aa6b579.tar.gz
0.1.133
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--Makefile14
-rw-r--r--PKGBUILD32
4 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9a0e74ba3f96
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Thu Jun 14 05:08:41 UTC 2018
+pkgbase = chef-workstation
+ pkgdesc = Chef Workstation gives you everything you need to get started with Chef. Start scanning and configuring your environments today with InSpec and chef-run.
+ pkgver = 0.1.133
+ pkgrel = 1
+ url = https://downloads.chef.io/chef-workstation/
+ arch = x86_64
+ license = Apache
+ conflicts = chef-dk
+ conflicts = chef
+ conflicts = chef-solo
+ conflicts = chef-client
+ source = https://packages.chef.io/files/stable/chef-workstation/0.1.133/ubuntu/18.04/chef-workstation_0.1.133-1_amd64.deb
+ sha256sums = 4a2171e5cebde6378b686ce2c7b35e8ff521b31eedfe7abb6b5179433592ded0
+
+pkgname = chef-workstation
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f05a7493bf44
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg/
+/src/
+/*.deb
+/*.tar.xz
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..1035977843b1
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,14 @@
+default: build
+
+build: namcap
+ makepkg
+ mksrcinfo
+
+namcap:
+ namcap PKGBUILD
+
+# too many failures we can't correct due to PKGBUILD design
+shellcheck:
+ shellcheck PKGBUILD
+
+vet: namcap shellcheck
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..da3ccf0a1131
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Trevor Bramble <inbox@trevorbramble.com>
+
+pkgname=chef-workstation
+pkgver=0.1.133
+pkgrel=1
+_ubunturel=18
+_ubuntuver=04
+pkgdesc="Chef Workstation gives you everything you need to get started with Chef. Start scanning and configuring your environments today with InSpec and chef-run."
+arch=('x86_64')
+url="https://downloads.chef.io/chef-workstation/"
+license=('Apache')
+depends=()
+conflicts=( chef-dk chef chef-solo chef-client )
+source=("https://packages.chef.io/files/stable/${pkgname}/${pkgver}/ubuntu/${_ubunturel}.${_ubuntuver}/${pkgname}_${pkgver}-1_amd64.deb")
+sha256sums=('4a2171e5cebde6378b686ce2c7b35e8ff521b31eedfe7abb6b5179433592ded0')
+
+package() {
+ cd "$srcdir"
+ bsdtar -xf data.tar.gz -C "$pkgdir"
+
+ mkdir -p "$pkgdir/usr/bin"
+
+ chefdk_binaries="berks chef chef-apply chef-client chef-shell chef-solo chef-vault cookstyle dco delivery foodcritic inspec kitchen knife ohai push-apply pushy-client pushy-service-manager"
+ binaries="chef-run chefx $chefdk_binaries"
+
+ for binary in $binaries; do
+ ln -s "/opt/$pkgname/bin/$binary" "$pkgdir/usr/bin/" || error_exit "Cannot link $binary to /usr/bin"
+ done
+
+ chown -Rh 0:0 "$pkgdir"
+ chmod -R 755 "$pkgdir/opt"
+}