summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNauval Rizky2023-05-22 12:12:37 +0700
committerNauval Rizky2023-05-22 12:20:22 +0700
commit50aa9b984f1a20527dc325d4d0ee54081adef4f5 (patch)
tree219180a03bb2ce4387ed6fa9340c8e45a9b4904f
downloadaur-50aa9b984f1a20527dc325d4d0ee54081adef4f5.tar.gz
Initial cherry-kde-git
This will became our official PKGBUILD in-place of the orphaned cherry-kde-theme package
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..51c8403df775
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = cherry-kde-git
+ pkgdesc = Clean, Flat, Δ Theme for KDE Plasma Desktop
+ pkgver = 1.6.r6.gf464d54
+ pkgrel = 1
+ url = https://github.com/nullxception/cherry-kde-theme
+ arch = any
+ license = GPL3
+ makedepends = git
+ optdepends = konsole: For the Konsole color scheme
+ optdepends = kvantum-qt5: For the Qt application style
+ provides = cherry-kde-theme
+ conflicts = cherry-kde-theme
+ options = !strip
+ source = cherry-kde-git::git+https://github.com/nullxception/cherry-kde-theme.git
+ sha256sums = SKIP
+
+pkgname = cherry-kde-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..034a3ec14601
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+pkgname=cherry-kde-git
+pkgver=1.6.r6.gf464d54
+pkgrel=1
+pkgdesc="Clean, Flat, Δ Theme for KDE Plasma Desktop"
+arch=('any')
+url="https://github.com/nullxception/cherry-kde-theme"
+license=('GPL3')
+optdepends=('konsole: For the Konsole color scheme'
+ 'kvantum-qt5: For the Qt application style')
+makedepends=('git')
+provides=("cherry-kde-theme")
+conflicts=("cherry-kde-theme")
+options=(!strip)
+source=("${pkgname}::git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "${pkgname}"
+ ./install.sh --prefix="${pkgdir}/usr" --clear-cache=false
+}