summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author6arms1leg2015-06-13 20:08:16 +0200
committer6arms1leg2015-06-13 20:08:16 +0200
commite528dfe39c24c6abdb04be8775ccec838537829a (patch)
treeba38948030ce1e3fcb11f1d1c6e0b408fa887469
downloadaur-e528dfe39c24c6abdb04be8775ccec838537829a.tar.gz
Initial import
-rw-r--r--.SRCINFO31
-rwxr-xr-xPKGBUILD33
-rwxr-xr-xcherrymusic.install20
-rwxr-xr-xcherrymusic@.service15
4 files changed, 99 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3a3d8853a57f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = cherrymusic
+ pkgdesc = A standalone HTML5 (with Flash fallback) music streaming server based on CherryPy and jPlayer.
+ pkgver = 0.35.2
+ pkgrel = 1
+ url = http://fomori.org/cherrymusic
+ install = cherrymusic.install
+ arch = any
+ license = GPL3
+ makedepends = python
+ depends = python>=3
+ depends = python-cherrypy>=3
+ depends = sqlite>=3
+ optdepends = python3-stagger-svn
+ optdepends = lame
+ optdepends = vorbis-tools
+ optdepends = flac
+ optdepends = faad2
+ optdepends = mpg123
+ optdepends = opus-tools
+ optdepends = ffmpeg
+ optdepends = imagemagick
+ optdepends = python-unidecode
+ optdepends = python-gobject
+ options = !emptydirs
+ source = cherrymusic-0.35.2.tar.gz::https://github.com/devsnd/cherrymusic/archive/0.35.2.tar.gz
+ source = cherrymusic@.service
+ sha512sums = 220f24a4b3344e0fe3d383cb809cf6e0c3e6b6fd2716f09b9c1165cb26e051ad416d91ade8566a6f90adbb501bdcb55e65f6f56de4e6529ffcc98654dc3713cf
+ sha512sums = 9d336a06492df0bb5718848f161895922d08171ab637b54fffad42fc5c12cd22d00f2408dabffc3617f0a59512276e38553f1c63a0ea68028982076b7f115165
+
+pkgname = cherrymusic
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..6468ca7aaef2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: 6arms1leg <m.brnsfld {at} googlemail {d0t} com>
+# Contributor: Tom Wallroth <tomwallroth {at} gmail {d0t} com>
+pkgname=cherrymusic
+pkgver=0.35.2
+pkgrel=1
+pkgdesc="A standalone HTML5 (with Flash fallback) music streaming server based on CherryPy and jPlayer."
+arch=('any')
+url="http://fomori.org/cherrymusic"
+license=('GPL3')
+depends=('python>=3' 'python-cherrypy>=3' 'sqlite>=3')
+makedepends=('python')
+optdepends=('python3-stagger-svn' 'lame' 'vorbis-tools' 'flac' 'faad2' 'mpg123' 'opus-tools' 'ffmpeg' 'imagemagick' 'python-unidecode' 'python-gobject')
+options=(!emptydirs)
+install=cherrymusic.install
+source=($pkgname-${pkgver//_/-}.tar.gz::https://github.com/devsnd/cherrymusic/archive/0.35.2.tar.gz 'cherrymusic@.service')
+sha512sums=('220f24a4b3344e0fe3d383cb809cf6e0c3e6b6fd2716f09b9c1165cb26e051ad416d91ade8566a6f90adbb501bdcb55e65f6f56de4e6529ffcc98654dc3713cf'
+ '9d336a06492df0bb5718848f161895922d08171ab637b54fffad42fc5c12cd22d00f2408dabffc3617f0a59512276e38553f1c63a0ea68028982076b7f115165')
+
+_mandir=/usr/share/man
+_systemdsfdir=/usr/lib/systemd/system
+
+package() {
+ cd "$srcdir/$pkgname-${pkgver//_/-}"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ echo -e '\033[1;32minstalling manpages...\033[0m'
+ install -Dm644 "doc/man/cherrymusic.1.gz" "$pkgdir$_mandir/man1/cherrymusic.1.gz"
+ install -Dm644 "doc/man/cherrymusic.conf.5.gz" "$pkgdir$_mandir/man5/cherrymusic.conf.5.gz"
+ install -Dm644 "doc/man/cherrymusicd.8.gz" "$pkgdir$_mandir/man8/cherrymusicd.8.gz"
+ echo -e '\033[1;32minstalling systemd service file...\033[0m'
+ install -Dm644 "$srcdir/cherrymusic@.service" "$pkgdir$_systemdsfdir/cherrymusic@.service"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/cherrymusic.install b/cherrymusic.install
new file mode 100755
index 000000000000..0d57b20e685c
--- /dev/null
+++ b/cherrymusic.install
@@ -0,0 +1,20 @@
+# arg 1: the new package version
+post_install() {
+ echo 'NOTE: On first startup CherryMusic generates the file'
+ echo ' "$XDG_CONFIG_HOME/cherrymusic/cherrymusic.conf" and exits. Edit this file'
+ echo ' and restart CherryMusic.'
+ echo ' Alternatively, start CherryMusic with the "--setup --port 8080" switch on'
+ echo ' first startup. This will walk you throught the most important'
+ echo ' configuration options in your web browser, when you open "localhost:8080".'
+ echo ' Please only use the provided systemd service file _after_ you started'
+ echo ' CherryMusic once manually with one of the methods above, so that the'
+ echo ' configuration files will be created and CherryMusic is set up properly.'
+ echo ' '
+ echo 'NOTE: This PKGBUILD provides a systemd service file. To start CherryMusic'
+ echo ' immediately and on boot using systemd, do (as root user):'
+ echo ' systemctl start cherrymusic@USER.service \ '
+ echo ' && systemctl enable cherrymusic@USER.service'
+ echo ' Where "USER" is the user that should run CherryMusic (do not use root!).'
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/cherrymusic@.service b/cherrymusic@.service
new file mode 100755
index 000000000000..cfa8f18ece94
--- /dev/null
+++ b/cherrymusic@.service
@@ -0,0 +1,15 @@
+[Unit]
+Description=CherryMusic server
+Requires=network.target
+After=network.target
+
+[Service]
+User=%I
+Type=simple
+ExecStart=/usr/bin/cherrymusic
+StandardOutput=null
+PrivateTmp=true
+Restart=always
+
+[Install]
+WantedBy=multi-user.target