summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoratemu2019-08-20 10:45:45 +0200
committeratemu2019-08-20 10:45:45 +0200
commit2cf05aac31f159f27ea48b4bfb2e5372b29dcc3b (patch)
tree98c8338f3252ccb6b7b6afc241f07ada233021bf
downloadaur-2cf05aac31f159f27ea48b4bfb2e5372b29dcc3b.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD21
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..83a5f8a880c9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = cherrytree-bin
+ pkgdesc = Binary version of cherrytree
+ pkgver = 0.38.9
+ pkgrel = 1
+ url = https://www.giuspen.com/cherrytree/
+ arch = any
+ license = GPL3
+ depends = pygtksourceview2
+ depends = python2-dbus
+ optdepends = python2-pyenchant: for spell checking support
+ optdepends = p7zip: for password protection support
+ source = http://www.giuspen.com/software/cherrytree_0.38.9-0_all.deb
+ sha256sums = SKIP
+
+pkgname = cherrytree-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4f425cdfcf52
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+pkgname=cherrytree-bin
+basename=${pkgname%*-bin}
+pkgver=0.38.9
+pkgrel=1
+pkgdesc='Binary version of cherrytree'
+arch=('any')
+url='https://www.giuspen.com/cherrytree/'
+license=('GPL3')
+depends=('pygtksourceview2' 'python2-dbus')
+optdepends=('python2-pyenchant: for spell checking support'
+ 'p7zip: for password protection support')
+source=(http://www.giuspen.com/software/$basename\_$pkgver-0_all.deb)
+sha256sums=('SKIP')
+
+package() {
+ msg2 "Extracting the data.tar.xz..."
+ bsdtar -xf data.tar.xz -C "$pkgdir/"
+ msg2 "Patching Python version..."
+ sed -i '1s/on/on2/' "$pkgdir"/usr/bin/cherrytree
+}
+