summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPRESFIL2020-10-21 19:48:31 +0300
committerPRESFIL2020-10-21 19:48:31 +0300
commit7148f58842b3ed971433f5d7bca074cd3f618127 (patch)
treee07dc24ba62d9f96a6003f4628851537faab13d1
parent775ee5b3688f51c601e91b48287d581787a57399 (diff)
downloadaur-7148f58842b3ed971433f5d7bca074cd3f618127.tar.gz
Bump version: 0.39.4 -> 0.99.16
Bumped from old, unmaintained Python 2 version to C++ version. Some dependencies may be missed.
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD16
2 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eed2945d902c..c6e59f7b4910 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = cherrytree-bin
pkgdesc = Binary version of cherrytree
- pkgver = 0.39.4
+ pkgver = 0.99.16
pkgrel = 1
url = https://www.giuspen.com/cherrytree/
- arch = any
+ arch = amd64
license = GPL3
- depends = python2-gtksourceview2
- depends = python2-dbus
- optdepends = python2-pyenchant: for spell checking support
+ depends = gtksourceviewmm
+ depends = libxml++2.6
+ depends = gspell
optdepends = p7zip: for password protection support
- source = http://www.giuspen.com/software/cherrytree_0.39.4-0_all.deb
+ source = https://launchpad.net/~giuspen/+archive/ubuntu/ppa/+files/cherrytree_0.99.16-1_amd64.deb
sha256sums = bddc893e19a3b37921fab7b9db7d5b1968432470d267d6931b60d30bf767793e
pkgname = cherrytree-bin
diff --git a/PKGBUILD b/PKGBUILD
index af5fba186a9e..8b132b766047 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,20 @@
+# Maintainer: PRESFIL <echo cHJlc2ZpbEBwcm90b25tYWlsLmNvbQo= | base64 -d>
+
pkgname=cherrytree-bin
-basename=${pkgname%*-bin}
-pkgver=0.39.4
+_basename=${pkgname%*-bin}
+pkgver=0.99.16
pkgrel=1
pkgdesc='Binary version of cherrytree'
-arch=('any')
+arch=('amd64')
url='https://www.giuspen.com/cherrytree/'
license=('GPL3')
-depends=('python2-gtksourceview2' 'python2-dbus')
-optdepends=('python2-pyenchant: for spell checking support' 'p7zip: for password protection support')
-source=(http://www.giuspen.com/software/$basename\_$pkgver-0_all.deb)
+depends=('gtksourceviewmm' 'libxml++2.6' 'gspell')
+optdepends=('p7zip: for password protection support')
+source=("https://launchpad.net/~giuspen/+archive/ubuntu/ppa/+files/${_basename}_${pkgver}-1_amd64.deb")
sha256sums=('bddc893e19a3b37921fab7b9db7d5b1968432470d267d6931b60d30bf767793e')
package() {
msg2 "Extracting the data.tar.xz..."
bsdtar -xf data.tar.xz -C "$pkgdir/"
- msg2 "Patching Python version..."
- sed -i '1s/on/on2/' "$pkgdir"/usr/bin/cherrytree
}