summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAtemu2020-02-24 21:20:59 +0100
committerAtemu2020-02-24 21:20:59 +0100
commit7b50e2448b07f31cc29c81878368039712d4680e (patch)
treee6638be7683820e52c5d0e5d1525ab2cef139b64
parent4e014c6d879e3edd54c7fa18dd6b4255c1c33f8a (diff)
downloadaur-7b50e2448b07f31cc29c81878368039712d4680e.tar.gz
Add shell.nix
This allows you to build the package on everything Nix runs on, now this dumbass can actually verify if what he changed actually builds when he's not near an Arch installation The fixup is needed because curl, rsync and scp are hard-coded to /usr/bin/ in makepkg.conf
-rw-r--r--shell.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 000000000000..186970a10032
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,17 @@
+{ pkgs ? import <nixpkgs> {} }:
+
+with pkgs;
+
+mkShell {
+ buildInputs = [
+ (pacman.overrideDerivation (old: {
+ postFixup = old.postFixup + ''
+ sed -i 's|/usr/bin/|${pkgs.coreutils}/bin/env |g' $out/etc/makepkg.conf
+ '';
+ }))
+ curl
+ fakeroot
+ file
+ libarchive # bsdtar
+ ];
+}