summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMorgenstern2023-08-26 12:51:35 +1200
committerMorgenstern2023-08-26 12:52:05 +1200
commit5debf1e4a2719a808bcc56984542df7863b0349e (patch)
tree91ddad9503def17b5e5c44b2d8de9c72ce39e012
parent7618b0bdc4dadf34dbb2e0b9674390ee22b1a760 (diff)
downloadaur-5debf1e4a2719a808bcc56984542df7863b0349e.tar.gz
Use git submodule spdlog until extra/spdlog>=1.12
Update PKGBUILD variables
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD42
2 files changed, 28 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a081559f2b4a..786d3da1de02 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cherrytree-git
pkgdesc = Hierarchical note-taking application, git version
- pkgver = 0.99.51.r2.gd54dd23e
+ pkgver = 1.0.1.r2.g08eec868
pkgrel = 1
url = https://github.com/giuspen/cherrytree
arch = x86_64
@@ -10,8 +10,6 @@ pkgbase = cherrytree-git
makedepends = cmake
makedepends = git
makedepends = python
- makedepends = spdlog
- depends = fmt
depends = gspell
depends = gtksourceviewmm
depends = libxml++2.6
@@ -20,6 +18,8 @@ pkgbase = cherrytree-git
provides = cherrytree
conflicts = cherrytree
source = git+https://github.com/giuspen/cherrytree.git
+ source = git+https://github.com/gabime/spdlog.git
+ sha512sums = SKIP
sha512sums = SKIP
pkgname = cherrytree-git
diff --git a/PKGBUILD b/PKGBUILD
index efa23b427e50..03faf36e04c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,49 +1,57 @@
# Maintainer: Morgenstern <charles [at] charlesbwise [dot] com>
pkgname=cherrytree-git
-_pkgname="${pkgname%%-git}"
-pkgver=0.99.51.r2.gd54dd23e
+pkgver=1.0.1.r2.g08eec868
pkgrel=1
pkgdesc="Hierarchical note-taking application, git version"
arch=('x86_64')
-url="https://github.com/giuspen/${_pkgname}"
+url="https://github.com/giuspen/${pkgname%%-git}"
license=('GPL3')
-depends=('fmt'
- 'gspell'
+depends=('gspell'
'gtksourceviewmm'
'libxml++2.6'
'uchardet'
'vte3')
makedepends=('cmake'
'git'
- 'python'
- 'spdlog')
+ 'python')
checkdepends=('gmock'
'gtest')
-provides=("${_pkgname}")
-conflicts=("${_pkgname}")
-source=("git+https://github.com/giuspen/${_pkgname}.git")
-sha512sums=('SKIP')
+provides=("${pkgname%%-git}")
+conflicts=("${pkgname%%-git}")
+source=("git+https://github.com/giuspen/${pkgname%%-git}.git"
+ "git+https://github.com/gabime/spdlog.git")
+sha512sums=('SKIP'
+ 'SKIP')
pkgver() {
- cd "${_pkgname}"
+ cd "${pkgname%%-git}"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+# Remove once extra/spdlog>=1.12
+prepare() {
+ cd "${pkgname%%-git}"
+ git submodule init
+ git config submodule.src/spdlog.url "${srcdir}/spdlog"
+ git -c protocol.file.allow=always submodule update
+}
+
build() {
cmake \
- -B "${_pkgname}/build" \
- -S "${_pkgname}" \
+ -B "${pkgname%%-git}/build" \
+ -S "${pkgname%%-git}" \
-DAUTO_RUN_TESTING:BOOL='OFF' \
-DUSE_SHARED_GTEST_GMOCK:BOOL='ON' \
+ -DUSE_SHARED_FMT_SPDLOG:BOOL='OFF' \
-Wno-dev
- make -C "${_pkgname}/build"
+ make -C "${pkgname%%-git}/build"
}
check() {
- ./"${_pkgname}/build/run_tests_no_x"
+ ./"${pkgname%%-git}/build/run_tests_no_x"
}
package() {
- make -C "${_pkgname}/build" DESTDIR="${pkgdir}" install
+ make -C "${pkgname%%-git}/build" DESTDIR="${pkgdir}" install
}