summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMorgenstern2022-10-28 01:05:01 +1300
committerMorgenstern2022-10-28 01:05:01 +1300
commit7618b0bdc4dadf34dbb2e0b9674390ee22b1a760 (patch)
treebee6ec9765f92e12ebf00813008f47c02b8ac284
parent2dc82118cdbebfb33c49503536290d786e6b10a5 (diff)
downloadaur-7618b0bdc4dadf34dbb2e0b9674390ee22b1a760.tar.gz
Execute "run_tests_no_x" for better chroot support
Remove optdepends xorg-xhost
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD9
2 files changed, 1 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2b38afa93fad..a081559f2b4a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -17,7 +17,6 @@ pkgbase = cherrytree-git
depends = libxml++2.6
depends = uchardet
depends = vte3
- optdepends = xorg-xhost: allow chroot access to X server for running tests
provides = cherrytree
conflicts = cherrytree
source = git+https://github.com/giuspen/cherrytree.git
diff --git a/PKGBUILD b/PKGBUILD
index 660007442dba..efa23b427e50 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,7 +20,6 @@ makedepends=('cmake'
'spdlog')
checkdepends=('gmock'
'gtest')
-optdepends=('xorg-xhost: allow chroot access to X server for running tests')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
source=("git+https://github.com/giuspen/${_pkgname}.git")
@@ -41,14 +40,8 @@ build() {
make -C "${_pkgname}/build"
}
-# NOTE: In order to run tests that depend on the X server in a clean chroot,
-# you must allow the chroot access your X server:
-# xhost +local:
-# https://wiki.archlinux.org/index.php/chroot#Run_graphical_applications_from_chroot
check() {
- export DISPLAY=:0
- ./"${_pkgname}/build/run_tests_with_x_1"
- ./"${_pkgname}/build/run_tests_with_x_2"
+ ./"${_pkgname}/build/run_tests_no_x"
}
package() {