summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMorgenstern2021-01-03 11:55:23 +1300
committerMorgenstern2021-01-03 11:55:23 +1300
commitb11119c093b02ef1b4b0ab30d1b1ead1088442e8 (patch)
treeea0e97bc47a80df551e64552b9112d662c6204ac
parent630e9ebd3553bf6f8d3d729b244f818bc981bbf9 (diff)
downloadaur-b11119c093b02ef1b4b0ab30d1b1ead1088442e8.tar.gz
Make check() function optional
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5adda74e5e16..813ea83ffcda 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -50,15 +50,15 @@ build() {
# NOTE: In order to run tests in a clean chroot, you must allow it access your X server:
# xhost +local:
# https://wiki.archlinux.org/index.php/chroot#Run_graphical_applications_from_chroot
-check() {
- export DISPLAY=:0
- cmake \
- -B "${_pkgname}/test-build" \
- -S "${_pkgname}" \
- -DINSTALL_GTEST:BOOL='OFF' \
- -Wno-dev
- make -C "${_pkgname}/test-build/tests"
-}
+#check() {
+# export DISPLAY=:0
+# cmake \
+# -B "${_pkgname}/test-build" \
+# -S "${_pkgname}" \
+# -DINSTALL_GTEST:BOOL='OFF' \
+# -Wno-dev
+# make -C "${_pkgname}/test-build/tests"
+#}
package() {
make -C "${_pkgname}/build" DESTDIR="${pkgdir}" install