summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMorgenstern2020-12-18 09:51:26 +1300
committerMorgenstern2020-12-18 09:51:26 +1300
commitccc898955d31f80d3ec2145f3d1cc951f0567e14 (patch)
tree55b83cf09ddd168d79413548089812346a3da358
parent4204daf41e69f16c3532b2846080b907d1464674 (diff)
downloadaur-ccc898955d31f80d3ec2145f3d1cc951f0567e14.tar.gz
Remove python-lxml dependency, fix optimisation flag override
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b8d4d55fc8fc..9b6b069d9ee0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = cherrytree-git
pkgdesc = Hierarchical note-taking application, git version
- pkgver = 0.99.19.r5.gcb239d48
+ pkgver = 0.99.25.r22.g7f00d91b
pkgrel = 1
url = https://github.com/giuspen/cherrytree
arch = x86_64
license = GPL3
makedepends = cmake
makedepends = git
- makedepends = python-lxml
+ makedepends = python
depends = gspell
depends = gtksourceviewmm
depends = libxml++2.6
diff --git a/PKGBUILD b/PKGBUILD
index b58203c43175..6557ea038d1c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,11 @@
pkgname=cherrytree-git
_pkgname="${pkgname%%-git}"
-pkgver=0.99.19.r5.gcb239d48
+pkgver=0.99.25.r22.g7f00d91b
pkgrel=1
pkgdesc="Hierarchical note-taking application, git version"
arch=('x86_64')
-url="https://github.com/giuspen/${_pkgname}"
+url="https://github.com/giuspen/cherrytree"
license=('GPL3')
depends=('gspell'
'gtksourceviewmm'
@@ -14,7 +14,7 @@ depends=('gspell'
'uchardet')
makedepends=('cmake'
'git'
- 'python-lxml')
+ 'python')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
source=("git+https://github.com/giuspen/${_pkgname}.git")
@@ -25,6 +25,11 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ # Fix automatic optimisation flag override
+ sed -i 's/-O3/-O2/' "${_pkgname}/CMakeLists.txt"
+}
+
build() {
cmake \
-B "${_pkgname}/build" \