summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAuguste Pop2015-06-11 15:52:22 +0800
committerAuguste Pop2015-06-11 15:52:22 +0800
commit248c3c1b83c440b21ca678a8b38beb0dd086b88e (patch)
tree51c313c9af17979e075e18ff2d981605d7478155
downloadaur-248c3c1b83c440b21ca678a8b38beb0dd086b88e.tar.gz
migrate from aur
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD25
-rw-r--r--merida.install18
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8caa4f80d3a2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = chess-merida
+ pkgdesc = A truetype chess font for diagrams and figurine notation
+ pkgver = 1.1
+ pkgrel = 1
+ url = http://www.enpassant.dk/chess/fonteng.htm
+ install = merida.install
+ arch = any
+ license = custom
+ makedepends = unzip
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = http://www.enpassant.dk/chess/downl/merid_tt.zip
+ source = merida.install
+ md5sums = fdd8933e38932cf91d971c0667f1d0b5
+ md5sums = 5ae0a6e3a2b9dd955467c59f8276e5c6
+
+pkgname = chess-merida
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a42f2ccac3a1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Auguste Pop <auguste [at] gmail [dot] com>
+
+pkgname=chess-merida
+pkgver=1.1
+pkgrel=1
+pkgdesc="A truetype chess font for diagrams and figurine notation"
+arch=('any')
+url="http://www.enpassant.dk/chess/fonteng.htm"
+license=('custom')
+depends=('fontconfig' 'xorg-font-utils')
+makedepends=('unzip')
+install=merida.install
+source=("http://www.enpassant.dk/chess/downl/merid_tt.zip"
+ 'merida.install')
+md5sums=('fdd8933e38932cf91d971c0667f1d0b5'
+ '5ae0a6e3a2b9dd955467c59f8276e5c6')
+
+package()
+{
+ cd $srcdir
+ install -m 644 -D MERIFONT.TTF \
+ $pkgdir/usr/share/fonts/TTF/ChessMerida.ttf
+ install -m 644 -D README_D.TXT \
+ $pkgdir/usr/share/licenses/$pkgname/README
+}
diff --git a/merida.install b/merida.install
new file mode 100644
index 000000000000..f29c33551317
--- /dev/null
+++ b/merida.install
@@ -0,0 +1,18 @@
+post_install()
+{
+ echo -n "Updating font cache... "
+ fc-cache -f >/dev/null
+ mkfontscale usr/share/fonts/TTF
+ mkfontdir usr/share/fonts/TTF
+ echo "done."
+}
+
+post_upgrade()
+{
+ post_install $1
+}
+
+post_remove()
+{
+ post_install $1
+}