summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter2018-08-13 19:57:19 +0000
committerPeter2018-08-13 19:57:19 +0000
commite3c4253cd121cba1eb9c55eb175b6f2add4726aa (patch)
treee5198b3eb5ee7f05d6c6f6e4d9ba71da07381c63
downloadaur-e3c4253cd121cba1eb9c55eb175b6f2add4726aa.tar.gz
first commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD41
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..149761ef4395
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = chesspp-git
+ pkgdesc = a swiss chess algorithm implementation, using an SQLITE database
+ pkgver = 0.0.0
+ pkgrel = 1
+ arch = x86_64
+ arch = i686
+ license = MIT
+ makedepends = git
+ makedepends = cmake
+ makedepends = ninja
+ depends = ncurses
+ source = chesspp::git+https://gitlab.com/Emersont1/chesspp.git#branch=master
+ md5sums = SKIP
+
+pkgname = chesspp-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7fb52e6468d9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Peter Taylot <info at emersont1 dot co dot uk>
+
+pkgname=chesspp-git
+pkgver=0.0.0
+pkgrel=1
+pkgdesc="a swiss chess algorithm implementation, using an SQLITE database"
+arch=('x86_64' 'i686')
+license=('MIT')
+depends=('ncurses')
+makedepends=('git' 'cmake' 'ninja')
+source=('chesspp::git+https://gitlab.com/Emersont1/chesspp.git#branch=master')
+md5sums=('SKIP')
+#install=robco-terminal.install
+
+build() {
+# don't think i need to do anything
+mkdir $PWD/$pkgname/build
+cd $PWD/$pkgname/build
+cmake ..
+make header_gen
+./tools/headergen/header_gen -f ../chesslib/game.sql
+make -j$(nproc)
+#ls .
+}
+
+#check() {
+# cd "$srcdir/${pkgname%-VCS}"
+# make -k check
+#}
+
+package() {
+
+ mkdir -p $pkgdir/usr/include
+ cp -r $PWD/$pkgname/chesslib/include/* $pkgdir/usr/include
+
+ mkdir -p $pkgdir/usr/lib
+ cp -r $PWD/$pkgname/build/chesslib/libchesspp.a $pkgdir/usr/lib
+
+ mkdir -p $pkgdir/usr/bin
+ cp -r $PWD/$pkgname/build/main_program/chess $pkgdir/usr/bin
+}