summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMunzir Taha2016-08-07 20:19:26 +0300
committerMunzir Taha2016-08-07 20:19:26 +0300
commit45f435db3372c1bc23083751e83ae65f7bafd80c (patch)
treee347be4722cb04c76fc871871c576811bc94940d
downloadaur-45f435db3372c1bc23083751e83ae65f7bafd80c.tar.gz
The stable version for chessx
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a733acec2b5e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = chessx
+ pkgdesc = Chess Database and PGN viewer
+ pkgver = 1.4.0
+ pkgrel = 1
+ url = http://chessx.sourceforge.net
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = qt5-tools
+ depends = qt5-multimedia
+ depends = qt5-svg
+ conflicts = chessx-svn
+ source = http://sourceforge.net/projects/chessx/files/chessx/1.4.0/chessx-1.4.0.tgz
+ sha256sums = e4287235904810a0a1b2cdec3dc33fbc30aa0657c7b7343bd2130bd9626220f4
+
+pkgname = chessx
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4b85337efd89
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Munzir Taha <munzirtaha@gmail.com>
+
+pkgname=chessx
+pkgver=1.4.0
+pkgrel=1
+pkgdesc="Chess Database and PGN viewer"
+arch=(i686 x86_64)
+url=http://chessx.sourceforge.net
+license=(GPL2)
+depends=(qt5-multimedia qt5-svg)
+makedepends=(qt5-tools)
+conflicts=($pkgname-svn)
+source=(http://sourceforge.net/projects/$pkgname/files/chessx/$pkgver/$pkgname-$pkgver.tgz)
+sha256sums=('e4287235904810a0a1b2cdec3dc33fbc30aa0657c7b7343bd2130bd9626220f4')
+
+build() {
+ cd $pkgname-$pkgver
+ qmake
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+ install -Dm644 "unix/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm644 data/images/$pkgname.png "$pkgdir/usr/share/pixmaps/$pkgname.png"
+ install -Dm755 release/$pkgname $pkgdir/usr/bin/$pkgname
+}