summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Waller2015-09-05 10:26:30 -0700
committerEric Waller2015-09-05 10:26:30 -0700
commit4b6b84a51e43e778a07407e550f282cba39478c1 (patch)
tree6f4ea337cc630ee998f3c708f42521f4249333ec
downloadaur-4b6b84a51e43e778a07407e550f282cba39478c1.tar.gz
Initial import
-rw-r--r--.SRCINFO47
-rw-r--r--PKGBUILD67
-rw-r--r--chessx-svn.install11
3 files changed, 125 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..89140bd7886f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,47 @@
+pkgbase = chessx-svn
+ pkgdesc = A free chess database
+ pkgver = 1.3.4.2124
+ pkgrel = 1
+ url = http://chessx.sourceforge.net
+ install = chessx-svn.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = subversion
+ makedepends = qt5-3d
+ makedepends = qt5-base
+ makedepends = qt5-canvas3d
+ makedepends = qt5-connectivity
+ makedepends = qt5-declarative
+ makedepends = qt5-enginio
+ makedepends = qt5-graphicaleffects
+ makedepends = qt5-imageformats
+ makedepends = qt5-location
+ makedepends = qt5-multimedia
+ makedepends = qt5-quick1
+ makedepends = qt5-quickcontrols
+ makedepends = qt5-script
+ makedepends = qt5-sensors
+ makedepends = qt5-serialport
+ makedepends = qt5-svg
+ makedepends = qt5-tools
+ makedepends = qt5-translations
+ makedepends = qt5-wayland
+ makedepends = qt5-webchannel
+ makedepends = qt5-webengine
+ makedepends = qt5-webkit
+ makedepends = qt5-websockets
+ makedepends = qt5-x11extras
+ makedepends = qt5-xmlpatterns
+ depends = qt5-svg
+ depends = desktop-file-utils
+ depends = qt5-multimedia
+ provides = chessx=1.3.4.2124
+ conflicts = chessx
+ options = !emptydirs
+ source = chessx-svn::svn+http://svn.code.sf.net/p/chessx/code/trunk
+ sha256sums = SKIP
+ sha512sums = SKIP
+
+pkgname = chessx-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a4559450af14
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,67 @@
+# Maintainer: Eric Waller <ewwaller+aur@gmail.com>
+# Contributor: Limao Luo <luolimao+AUR@gmail.com>
+
+pkgname=chessx-svn
+pkgver=1.3.4.2124
+pkgrel=1
+pkgdesc="A free chess database"
+arch=(i686 x86_64)
+url=http://chessx.sourceforge.net
+license=(GPL2)
+depends=(qt5-svg desktop-file-utils qt5-multimedia)
+makedepends=(subversion
+ qt5-3d
+ qt5-base
+ qt5-canvas3d
+ qt5-connectivity
+ qt5-declarative
+ qt5-enginio
+ qt5-graphicaleffects
+ qt5-imageformats
+ qt5-location
+ qt5-multimedia
+ qt5-quick1
+ qt5-quickcontrols
+ qt5-script
+ qt5-sensors
+ qt5-serialport
+ qt5-svg
+ qt5-tools
+ qt5-translations
+ qt5-wayland
+ qt5-webchannel
+ qt5-webengine
+ qt5-webkit
+ qt5-websockets
+ qt5-x11extras
+ qt5-xmlpatterns
+)
+
+provides=(${pkgname%-*}=$pkgver)
+conflicts=(${pkgname%-*})
+options=(!emptydirs)
+install=$pkgname.install
+source=($pkgname::svn+http://svn.code.sf.net/p/${pkgname%-*}/code/trunk)
+sha256sums=('SKIP')
+sha512sums=('SKIP')
+
+pkgver() {
+ echo $(grep -o 'Version [0-9.]\+' -m1 $pkgname/ChangeLog | tr -d '[a-zA-Z ]').$(svnversion "$SRCDEST"/$pkgname/)
+}
+
+prepare() {
+ sed -i 's:qm:ts:g' $pkgname/resources.qrc
+}
+
+build() {
+ cd $pkgname/
+ qmake-qt5
+ make
+}
+
+package() {
+ cd $pkgname/
+ desktop-file-install unix/${pkgname%-*}.desktop --dir "$pkgdir"/usr/share/applications/
+ install -Dm644 data/images/${pkgname%-*}.png "$pkgdir"/usr/share/pixmaps/${pkgname%-*}.png
+ install -Dm755 release/${pkgname%-*} "$pkgdir"/usr/bin/${pkgname%-*}
+}
diff --git a/chessx-svn.install b/chessx-svn.install
new file mode 100644
index 000000000000..660593cf5668
--- /dev/null
+++ b/chessx-svn.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}