summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTércio Martins2019-10-27 03:03:24 -0300
committerTércio Martins2019-10-27 03:03:24 -0300
commit8e8ad5dcce39cc4085b14669d7e161cae823a121 (patch)
treecf7f5b5c4dd04dc1bc2b1f2bf32655577b7ead29
downloadaur-8e8ad5dcce39cc4085b14669d7e161cae823a121.tar.gz
Adding PKGBUILD to AUR
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD41
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..360140efa9aa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = chestnut-git
+ pkgdesc = An open-source NLE video editor; fork of Olive-Editor
+ pkgver = v0.1.0.r5.geaae54b
+ pkgrel = 1
+ url = https://github.com/jonno85uk/chestnut
+ arch = i686
+ arch = pentium4
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = ffmpeg
+ depends = qt5-multimedia
+ depends = qt5-svg
+ optdepends = olive-community-effects-git
+ source = chestnut::git+https://github.com/jonno85uk/chestnut.git
+ sha512sums = SKIP
+
+pkgname = chestnut-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..58235cbd34ba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Tércio Martins <echo dGVyY2lvd2VuZGVsQGdtYWlsLmNvbQo= | base64 -d>
+
+pkgname=chestnut-git
+_pkgname=chestnut
+pkgver=v0.1.0.r5.geaae54b
+pkgrel=1
+arch=('i686' 'pentium4' 'x86_64')
+pkgdesc="An open-source NLE video editor; fork of Olive-Editor"
+url="https://github.com/jonno85uk/chestnut"
+license=('GPL3')
+depends=('ffmpeg' 'qt5-multimedia' 'qt5-svg')
+makedepends=('git')
+optdepends=('olive-community-effects-git')
+source=("$_pkgname::git+https://github.com/jonno85uk/chestnut.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ qmake CONFIG+=release PREFIX=/usr
+ make
+
+ cd "$srcdir/$_pkgname/packaging/appimage/"
+ sed -n '/Desktop/,/AudioVideo/p' chestnut.yml | sed 's/\ \ -\ //g' > \
+ chestnut.desktop
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ make INSTALL_ROOT="$pkgdir" install
+
+ install -Dm 644 "$srcdir/$_pkgname/packaging/appimage/chestnut.desktop" \
+ "$pkgdir/usr/share/applications/chestnut.desktop"
+
+ install -Dm 644 "$srcdir/$_pkgname/app/icons/chestnut.png" \
+ "$pkgdir/usr/share/pixmaps/chestnut.png"
+}