summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-04-01 09:43:24 +0800
committerSukanka2022-04-01 09:43:24 +0800
commitdb68f5752550cf30f9aaa6ee4a823ee56eab0b6b (patch)
tree83aa8d481026454f20db8631270b8cd2e25716a2
parent6eb0751016cf3c1b527c930279271f8b14cf626f (diff)
downloadaur-chevereto.tar.gz
update 1.6.2
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD19
2 files changed, 12 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8d9ad6abed4e..fc87cfa61dce 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = chevereto
pkgdesc = Chevereto is an image hosting script that allows you to create a beautiful and full-featured image hosting website on your own server.
- pkgver = 1.1.4
+ pkgver = 1.6.2
pkgrel = 1
url = https://chevereto.com/free
install = chevereto.install
@@ -10,11 +10,11 @@ pkgbase = chevereto
depends = php-gd
depends = mariadb
optdepends = php-apache: to use the Apache web server
+ optdepends = nginx: web server
options = emptydirs
- source = https://github.com/Chevereto/Chevereto-Free/archive/1.1.4.tar.gz
+ source = https://github.com/Chevereto/Chevereto-Free/archive/1.6.2.tar.gz
source = chevereto.perm.sh
- md5sums = 90515a682a2b5974dd3410650e019e76
- md5sums = e7add39512c475948c6709a0a6a9c309
+ sha256sums = 4636e24511a0ae7abd27aadd57bc6b08735f9fb8ad6fba11c9142c9e9317f8dc
+ sha256sums = 0d8db5e6a5aa237c6efd8878782f49b44788ef464584cea8113528f6cff793cd
pkgname = chevereto
-
diff --git a/PKGBUILD b/PKGBUILD
index 8e701b99bae8..4a901efb8441 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,27 @@
pkgname=chevereto
-pkgver=1.1.4
+pkgver=1.6.2
pkgrel=1
pkgdesc="Chevereto is an image hosting script that allows you to create a beautiful and full-featured image hosting website on your own server."
arch=(any)
url="https://chevereto.com/free"
license=("AGPL")
-optdepends=('php-apache: to use the Apache web server')
+optdepends=('php-apache: to use the Apache web server'
+'nginx: web server'
+)
depends=("php" "php-gd" "mariadb")
install=chevereto.install
options=(emptydirs)
source=(https://github.com/Chevereto/Chevereto-Free/archive/${pkgver}.tar.gz
chevereto.perm.sh)
-md5sums=('90515a682a2b5974dd3410650e019e76'
- 'e7add39512c475948c6709a0a6a9c309')
-
-
-pkgver() {
- curl -Is https://github.com/Chevereto/Chevereto-Free/releases/latest | awk -F'/' '/^Location/ {print $NF}' | sed 's/[^[:print:]]//'
-
-}
-
+sha256sums=('4636e24511a0ae7abd27aadd57bc6b08735f9fb8ad6fba11c9142c9e9317f8dc'
+ '0d8db5e6a5aa237c6efd8878782f49b44788ef464584cea8113528f6cff793cd')
package() {
mkdir -p "${pkgdir}/usr/share/webapps"
- cp -a Chevereto-Free-$pkgver "${pkgdir}/usr/share/webapps/chevereto"
+ cp -a chevereto-free-$pkgver "${pkgdir}/usr/share/webapps/chevereto"
install -D -m755 "${srcdir}/chevereto.perm.sh" "${pkgdir}/usr/bin/set-chevereto-perm"
}