summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFanch2018-11-27 00:01:53 +0100
committerFanch2018-11-27 00:01:53 +0100
commitdd2a9546625203b306f99daad38e6e36e07cc7db (patch)
tree2e27d13b2e648f138d85c9e0195751c2eb0a3b08
downloadaur-dd2a9546625203b306f99daad38e6e36e07cc7db.tar.gz
Update Version
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD25
-rw-r--r--chevereto.install7
-rw-r--r--chevereto.perm.sh9
4 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8d465389c38f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = chevereto
+ pkgdesc = Chevereto is an image hosting script that allows you to create a beautiful and full-featured image hosting website on your own server.
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = https://chevereto.com/free
+ install = chevereto.install
+ arch = any
+ license = GPL
+ depends = php
+ depends = php-gd
+ depends = mariadb
+ options = emptydirs
+ source = https://github.com/Chevereto/Chevereto-Free/archive/1.1.0.tar.gz
+ source = chevereto.perm.sh
+ md5sums = 694fa397ea504e8eb018c5b8392a7c84
+ md5sums = e7add39512c475948c6709a0a6a9c309
+
+pkgname = chevereto
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1aff93aea511
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+pkgname=chevereto
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="Chevereto is an image hosting script that allows you to create a beautiful and full-featured image hosting website on your own server."
+arch=(any)
+url="https://chevereto.com/free"
+license=("GPL")
+depends=("php" "php-gd" "mariadb")
+install=chevereto.install
+options=(emptydirs)
+
+source=(https://github.com/Chevereto/Chevereto-Free/archive/${pkgver}.tar.gz
+ chevereto.perm.sh)
+md5sums=('694fa397ea504e8eb018c5b8392a7c84'
+ 'e7add39512c475948c6709a0a6a9c309')
+
+
+
+package() {
+
+ mkdir -p "${pkgdir}/usr/share/webapps"
+ cp -a Chevereto-Free-$pkgver "${pkgdir}/usr/share/webapps/chevereto"
+
+ install -D -m755 "${srcdir}/chevereto.perm.sh" "${pkgdir}/usr/bin/set-chevereto-perm"
+}
diff --git a/chevereto.install b/chevereto.install
new file mode 100644
index 000000000000..608820c8eba3
--- /dev/null
+++ b/chevereto.install
@@ -0,0 +1,7 @@
+post_install () {
+ set-chevereto-perm
+}
+
+post_upgrade() {
+ set-chevereto-perm
+} \ No newline at end of file
diff --git a/chevereto.perm.sh b/chevereto.perm.sh
new file mode 100644
index 000000000000..cbdb6794cb48
--- /dev/null
+++ b/chevereto.perm.sh
@@ -0,0 +1,9 @@
+#!/bin/bash
+
+chevereto_path='/usr/share/webapps/chevereto'
+htuser='http'
+htgroup='http'
+
+find ${chevereto_path}/ -type f -print0 | xargs -0 chmod 0640
+find ${chevereto_path}/ -type d -print0 | xargs -0 chmod 0750
+chown -R ${htuser}:${htgroup} ${chevereto_path}/