summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12016-03-16 07:00:49 +0800
committerChocobo12016-03-16 07:00:49 +0800
commitb01344735f6c6ae90af42a430248ff2cf125a69e (patch)
tree97d278fe8b3e83d469beb4c09abe59f4cca76a48
downloadaur-b01344735f6c6ae90af42a430248ff2cf125a69e.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD40
-rw-r--r--chewing-editor.install12
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5b57554e8ba7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = chewing-editor
+ pkgdesc = Cross platform chewing user phrase editor
+ pkgver = 0.0.2
+ pkgrel = 1
+ url = http://chewing.im
+ install = chewing-editor.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = BSD
+ makedepends = cmake
+ makedepends = qt5-tools
+ depends = libchewing
+ depends = qt5-base
+ depends = hicolor-icon-theme
+ source = https://github.com/chewing/chewing-editor/archive/0.0.2.tar.gz
+ sha256sums = 1ce0a98d7cbabe3d03d8dcc9bd1b0a05b8dd37d069b60cbf83bd4cef99939367
+
+pkgname = chewing-editor
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..15800babe949
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Mike Tzou <github27049215-aru AT yahoo.com.tw>
+
+pkgname=chewing-editor
+pkgver=0.0.2
+pkgrel=1
+pkgdesc="Cross platform chewing user phrase editor"
+arch=('i686' 'x86_64')
+url="http://chewing.im"
+license=('GPL' 'BSD')
+depends=('libchewing' 'qt5-base' 'hicolor-icon-theme')
+makedepends=('cmake' 'qt5-tools')
+install=$pkgname.install
+source=("https://github.com/chewing/$pkgname/archive/$pkgver.tar.gz")
+sha256sums=('1ce0a98d7cbabe3d03d8dcc9bd1b0a05b8dd37d069b60cbf83bd4cef99939367')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ mkdir build
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver/build"
+
+ cmake ../ -DCMAKE_INSTALL_PREFIX='/usr'
+ make
+}
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver/build"
+
+ ./run-test
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver/build"
+
+ make DESTDIR="$pkgdir" install
+ install -Dm644 ../COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}
diff --git a/chewing-editor.install b/chewing-editor.install
new file mode 100644
index 000000000000..5c501dc49916
--- /dev/null
+++ b/chewing-editor.install
@@ -0,0 +1,12 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}