summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12017-08-12 14:38:08 +0800
committerChocobo12017-08-12 14:38:08 +0800
commit62ab20c970000406d640d07c24eff41084625f2c (patch)
tree6406eb9eb7d094f49880a6b51c7964509bc2ab01
parenta55eaaf715ef8a362add30c74b617df670def344 (diff)
downloadaur-62ab20c970000406d640d07c24eff41084625f2c.tar.gz
upgpkg: chewing-editor-git 0.1.1.r37.g9f25170-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
-rw-r--r--qtchooser-notfound.patch32
3 files changed, 6 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5665fe38aa14..1e715fc7297d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = chewing-editor-git
pkgdesc = Cross platform chewing user phrase editor
- pkgver = 0.1.1.r30.g637be39
- pkgrel = 2
+ pkgver = 0.1.1.r37.g9f25170
+ pkgrel = 1
url = http://chewing.im
arch = i686
arch = x86_64
@@ -16,9 +16,7 @@ pkgbase = chewing-editor-git
provides = chewing-editor
conflicts = chewing-editor
source = git+https://github.com/chewing/chewing-editor.git
- source = qtchooser-notfound.patch
sha256sums = SKIP
- sha256sums = aea1b4df5654394aa41aac08048d5d60a0b5bd735eb4ed246b219ded9ea62fd2
pkgname = chewing-editor-git
diff --git a/PKGBUILD b/PKGBUILD
index 99bf0ec6d009..b6cf3c4b9715 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=chewing-editor-git
-pkgver=0.1.1.r30.g637be39
-pkgrel=2
+pkgver=0.1.1.r37.g9f25170
+pkgrel=1
pkgdesc="Cross platform chewing user phrase editor"
arch=('i686' 'x86_64')
url="http://chewing.im"
@@ -11,16 +11,13 @@ depends=('libchewing' 'qt5-base' 'hicolor-icon-theme')
makedepends=('git' 'cmake' 'qt5-tools' 'help2man')
provides=('chewing-editor')
conflicts=('chewing-editor')
-source=("git+https://github.com/chewing/chewing-editor.git"
- qtchooser-notfound.patch)
-sha256sums=('SKIP'
- 'aea1b4df5654394aa41aac08048d5d60a0b5bd735eb4ed246b219ded9ea62fd2')
+source=("git+https://github.com/chewing/chewing-editor.git")
+sha256sums=('SKIP')
prepare() {
cd "chewing-editor"
- patch -Np1 -i "../qtchooser-notfound.patch"
mkdir -p "build"
}
diff --git a/qtchooser-notfound.patch b/qtchooser-notfound.patch
deleted file mode 100644
index dbb2c9765dc6..000000000000
--- a/qtchooser-notfound.patch
+++ /dev/null
@@ -1,32 +0,0 @@
---- chewing-editor/CMakeLists-orig.txt 2016-10-30 15:20:22.920457000 +0800
-+++ chewing-editor/CMakeLists.txt 2016-10-30 15:23:17.850457999 +0800
-@@ -48,11 +48,6 @@
- find_package(PkgConfig)
- find_package(Qt5Widgets REQUIRED)
-
--find_program(QTCHOOSER qtchooser)
--if (NOT QTCHOOSER)
-- message(SEND_ERROR "Cannot find qtchooser")
--endif()
--
- # libchewing
- # MODIFY IF NEEDED, e.g. ${CMAKE_CURRENT_SOURCE_DIR}/libchewing/lib/*.lib
- set(CHEWING_LIBRARIES )
-@@ -139,7 +134,7 @@
- set(QM_FILE "${QM_DIR}/${CMAKE_PROJECT_NAME}_${TRANSLATION}.qm")
-
- add_custom_target("${TRANSLATION}-ts"
-- COMMAND ${QTCHOOSER} -run-tool=lupdate -qt=${QT_VERSION} -${PROJECT_SOURCE_DIR}/src -ts ${TS_FILE}
-+ COMMAND lupdate-qt5 -${PROJECT_SOURCE_DIR}/src -ts ${TS_FILE}
- DEPENDS prepare_lupdate
- )
- add_dependencies(lupdate "${TRANSLATION}-ts")
-@@ -147,7 +142,7 @@
- add_custom_command(
- OUTPUT
- ${QM_FILE}
-- COMMAND ${QTCHOOSER} -run-tool=lrelease -qt=${QT_VERSION} ${TS_FILE} -qm ${QM_FILE}
-+ COMMAND lrelease-qt5 ${TS_FILE} -qm ${QM_FILE}
- DEPENDS
- prepare_lrelease
- ${TS_FILE}