summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12016-10-30 15:17:44 +0800
committerChocobo12016-10-30 15:31:14 +0800
commitd2652fe3fdf8fa01b9894cf2094798aab81000da (patch)
treeac01c6c7c447c19239b2f5ed68d0e923fdff3b36
parent194fd505252e5387f6b6c9fb90d5889b355270c8 (diff)
downloadaur-d2652fe3fdf8fa01b9894cf2094798aab81000da.tar.gz
upgpkg: chewing-editor-git 0.1.1.r30.g637be39-1
Add qtchooser-notfound.patch
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
-rw-r--r--qtchooser-notfound.patch32
3 files changed, 43 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3b33e1a45b02..9120f58d1a13 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = chewing-editor-git
pkgdesc = Cross platform chewing user phrase editor
- pkgver = 0.1.1.r28.ge79a521
+ pkgver = 0.1.1.r30.g637be39
pkgrel = 1
url = http://chewing.im
arch = i686
@@ -14,7 +14,9 @@ pkgbase = chewing-editor-git
depends = qt5-base
depends = hicolor-icon-theme
source = git+https://github.com/chewing/chewing-editor.git
- md5sums = SKIP
+ source = qtchooser-notfound.patch
+ sha256sums = SKIP
+ sha256sums = aea1b4df5654394aa41aac08048d5d60a0b5bd735eb4ed246b219ded9ea62fd2
pkgname = chewing-editor-git
diff --git a/PKGBUILD b/PKGBUILD
index 218b2d4197f0..5f88b39b741c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Chocobo1
pkgname=chewing-editor-git
-pkgver=0.1.1.r28.ge79a521
+pkgver=0.1.1.r30.g637be39
pkgrel=1
pkgdesc="Cross platform chewing user phrase editor"
arch=('i686' 'x86_64')
@@ -9,8 +9,11 @@ url="http://chewing.im"
license=('GPL')
depends=('libchewing' 'qt5-base' 'hicolor-icon-theme')
makedepends=('git' 'cmake' 'qt5-tools' 'help2man')
-source=("git+https://github.com/chewing/chewing-editor.git")
-md5sums=('SKIP')
+source=("git+https://github.com/chewing/chewing-editor.git"
+ qtchooser-notfound.patch)
+sha256sums=('SKIP'
+ 'aea1b4df5654394aa41aac08048d5d60a0b5bd735eb4ed246b219ded9ea62fd2')
+
pkgver() {
cd "chewing-editor"
@@ -21,6 +24,7 @@ pkgver() {
prepare() {
cd "chewing-editor"
+ patch -Np1 -i ../qtchooser-notfound.patch
mkdir -p build
}
diff --git a/qtchooser-notfound.patch b/qtchooser-notfound.patch
new file mode 100644
index 000000000000..dbb2c9765dc6
--- /dev/null
+++ b/qtchooser-notfound.patch
@@ -0,0 +1,32 @@
+--- chewing-editor/CMakeLists-orig.txt 2016-10-30 15:20:22.920457000 +0800
++++ chewing-editor/CMakeLists.txt 2016-10-30 15:23:17.850457999 +0800
+@@ -48,11 +48,6 @@
+ find_package(PkgConfig)
+ find_package(Qt5Widgets REQUIRED)
+
+-find_program(QTCHOOSER qtchooser)
+-if (NOT QTCHOOSER)
+- message(SEND_ERROR "Cannot find qtchooser")
+-endif()
+-
+ # libchewing
+ # MODIFY IF NEEDED, e.g. ${CMAKE_CURRENT_SOURCE_DIR}/libchewing/lib/*.lib
+ set(CHEWING_LIBRARIES )
+@@ -139,7 +134,7 @@
+ set(QM_FILE "${QM_DIR}/${CMAKE_PROJECT_NAME}_${TRANSLATION}.qm")
+
+ add_custom_target("${TRANSLATION}-ts"
+- COMMAND ${QTCHOOSER} -run-tool=lupdate -qt=${QT_VERSION} -${PROJECT_SOURCE_DIR}/src -ts ${TS_FILE}
++ COMMAND lupdate-qt5 -${PROJECT_SOURCE_DIR}/src -ts ${TS_FILE}
+ DEPENDS prepare_lupdate
+ )
+ add_dependencies(lupdate "${TRANSLATION}-ts")
+@@ -147,7 +142,7 @@
+ add_custom_command(
+ OUTPUT
+ ${QM_FILE}
+- COMMAND ${QTCHOOSER} -run-tool=lrelease -qt=${QT_VERSION} ${TS_FILE} -qm ${QM_FILE}
++ COMMAND lrelease-qt5 ${TS_FILE} -qm ${QM_FILE}
+ DEPENDS
+ prepare_lrelease
+ ${TS_FILE}