summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12020-10-07 13:21:15 +0800
committerChocobo12020-10-07 13:21:15 +0800
commitdf598d5c17a7b8c8aa574013362efcb011eb01ed (patch)
treef3e74f255cdbb924a52be9973947cc1fd15b82f5
parent5a9b90ffd0c66872de4ddcd75d437e03c3967fe7 (diff)
downloadaur-df598d5c17a7b8c8aa574013362efcb011eb01ed.tar.gz
upgpkg: chewing-editor-git 0.1.1.r39.gfdea9ac-1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD32
2 files changed, 19 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 91a8f920c553..dbea0880d018 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = chewing-editor-git
pkgdesc = Cross platform chewing user phrase editor
- pkgver = 0.1.1.r37.g9f25170
- pkgrel = 2
+ pkgver = 0.1.1.r39.gfdea9ac
+ pkgrel = 1
url = http://chewing.im
arch = i686
arch = x86_64
@@ -9,12 +9,12 @@ pkgbase = chewing-editor-git
checkdepends = valgrind
makedepends = git
makedepends = cmake
- makedepends = qt5-tools
makedepends = help2man
+ makedepends = qt5-tools
depends = glibc
+ depends = hicolor-icon-theme
depends = libchewing
depends = qt5-base
- depends = hicolor-icon-theme
provides = chewing-editor
conflicts = chewing-editor
source = git+https://github.com/chewing/chewing-editor.git
diff --git a/PKGBUILD b/PKGBUILD
index 6cdcfb5b7c43..fe670397f7b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=chewing-editor-git
-pkgver=0.1.1.r37.g9f25170
-pkgrel=2
+pkgver=0.1.1.r39.gfdea9ac
+pkgrel=1
pkgdesc="Cross platform chewing user phrase editor"
arch=('i686' 'x86_64')
url="http://chewing.im"
license=('GPL')
-depends=('glibc' 'libchewing' 'qt5-base' 'hicolor-icon-theme')
-makedepends=('git' 'cmake' 'qt5-tools' 'help2man')
+depends=('glibc' 'hicolor-icon-theme' 'libchewing' 'qt5-base')
+makedepends=('git' 'cmake' 'help2man' 'qt5-tools')
checkdepends=('valgrind')
provides=('chewing-editor')
conflicts=('chewing-editor')
@@ -16,12 +16,6 @@ source=("git+https://github.com/chewing/chewing-editor.git")
sha256sums=('SKIP')
-prepare() {
- cd "chewing-editor"
-
- mkdir -p "_build"
-}
-
pkgver() {
cd "chewing-editor"
@@ -29,20 +23,24 @@ pkgver() {
}
build() {
- cd "chewing-editor/_build"
+ cd "chewing-editor"
- cmake -DCMAKE_INSTALL_PREFIX="/usr" DCMAKE_BUILD_TYPE=Release ../
- make
+ cmake \
+ -B "_build" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ ./
+ make -C "_build"
}
check() {
- cd "chewing-editor/_build"
+ cd "chewing-editor"
- make test
+ make -C "_build" test
}
package() {
- cd "chewing-editor/_build"
+ cd "chewing-editor"
- make DESTDIR="$pkgdir" install
+ make -C "_build" DESTDIR="$pkgdir" install
}