summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordgeibi2017-10-13 13:40:25 +0800
committerdgeibi2017-10-13 13:40:25 +0800
commitd70453d1150ef6c584e19ee8e08ed52c9043346a (patch)
tree46b2af4346ce8fd3340bd4a644e912084cac7a65
parentd7b35e96137999002722b30693e529f5e7f2c60c (diff)
downloadaur-d70453d1150ef6c584e19ee8e08ed52c9043346a.tar.gz
Update version to 9.5
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD37
2 files changed, 21 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 32f3b360e183..cf9ec195c64d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = chez-scheme
pkgdesc = Chez Scheme is a compiler and run-time system for the language of the Revised^6 Report on Scheme (R6RS), with numerous extensions.
- pkgver = 9.4
- pkgrel = 2
+ pkgver = 9.5
+ pkgrel = 1
url = https://github.com/cisco/ChezScheme
arch = i686
arch = x86_64
@@ -15,14 +15,8 @@ pkgbase = chez-scheme
conflicts = chez-scheme-git
replaces = petite-chez-scheme
replaces = chez-scheme-git
- source = https://github.com/cisco/ChezScheme/archive/v9.4.tar.gz
- source = https://github.com/nanopass/nanopass-framework-scheme/archive/221eecb965d9dfacccd97d1cb73f2a31c4119d3a.zip
- source = https://github.com/dybvig/stex/archive/3bd2b86cc5ae1797d05fc5cc6f11cc43383f741d.zip
- source = https://github.com/madler/zlib/archive/50893291621658f355bc5b4d450a8d06a563053d.zip
- sha1sums = f1273793cbceb545e51baa2cbf1be1d9c870c8f4
- sha1sums = 0d9f54741c4f0af31255241f98087aedced0e5e7
- sha1sums = 91445bc89d4d377b1008c314d069bed74094d892
- sha1sums = b6e1ad0c47a5f620d10d3e19efd46b1762a80510
+ source = https://github.com/cisco/ChezScheme/releases/download/v9.5/csv9.5.tar.gz
+ sha1sums = fcbda13bb61643209fd5d825e393d2064dc6c5be
pkgname = chez-scheme
diff --git a/PKGBUILD b/PKGBUILD
index a2ef5ab0e13d..713411151bf7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Xavier Peng <png.inside@gmail.com>
pkgname=chez-scheme
-pkgver=9.4
-pkgrel=2
+pkgver=9.5
+pkgrel=1
pkgdesc="Chez Scheme is a compiler and run-time system for the language of the Revised^6 Report on Scheme (R6RS), with numerous extensions."
arch=(i686 x86_64)
url="https://github.com/cisco/ChezScheme"
@@ -11,27 +11,24 @@ license=('APL')
makedepends=('binutils' 'make' 'ncurses' 'libx11' 'xproto')
conflicts=('petite-chez-scheme' 'chez-scheme-git')
replaces=('petite-chez-scheme' 'chez-scheme-git')
-source=('https://github.com/cisco/ChezScheme/archive/v9.4.tar.gz'
- 'https://github.com/nanopass/nanopass-framework-scheme/archive/221eecb965d9dfacccd97d1cb73f2a31c4119d3a.zip'
- 'https://github.com/dybvig/stex/archive/3bd2b86cc5ae1797d05fc5cc6f11cc43383f741d.zip'
- 'https://github.com/madler/zlib/archive/50893291621658f355bc5b4d450a8d06a563053d.zip')
-sha1sums=('f1273793cbceb545e51baa2cbf1be1d9c870c8f4'
- '0d9f54741c4f0af31255241f98087aedced0e5e7'
- '91445bc89d4d377b1008c314d069bed74094d892'
- 'b6e1ad0c47a5f620d10d3e19efd46b1762a80510')
-_archivename=ChezScheme-$pkgver
+source=("https://github.com/cisco/ChezScheme/releases/download/v9.5/csv9.5.tar.gz")
+sha1sums=('fcbda13bb61643209fd5d825e393d2064dc6c5be')
+_archivename=csv$pkgver
+
+prepare() {
+ cd "$srcdir/${_archivename}" || exit
+ # copy from Jonathon Fernyhough, glibc=2.26 dropped xlocale.h, this is a hacky workaround
+ cp /usr/include/locale.h zlib/xlocale.h
+}
build() {
- cd "$srcdir/${_archivename}" || exit
- rm -r nanopass/ stex/ zlib/
- mv ../nanopass-framework-scheme-221eecb965d9dfacccd97d1cb73f2a31c4119d3a ./nanopass
- mv ../stex-3bd2b86cc5ae1797d05fc5cc6f11cc43383f741d ./stex
- mv ../zlib-50893291621658f355bc5b4d450a8d06a563053d ./zlib
- ./configure --installprefix=/usr --temproot=$pkgdir
- make
+ cd "$srcdir/${_archivename}" || exit
+ unset CHEZSCHEMELIBDIRS
+ ./configure --installprefix=/usr --temproot=$pkgdir
+ make
}
package() {
- cd "${srcdir}/${_archivename}" || exit
- make install DESTDIR="$pkgdir"
+ cd "${srcdir}/${_archivename}" || exit
+ make install DESTDIR="$pkgdir"
}