summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArvid Norlander2023-04-21 14:09:50 +0200
committerArvid Norlander2023-04-21 14:09:50 +0200
commit5eb108688c9ee8b8dd7f413114a0e294c6261e07 (patch)
tree6c046d324fed493adc220e33b60134ea95f9bd5f
downloadaur-5eb108688c9ee8b8dd7f413114a0e294c6261e07.tar.gz
Create repository
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD53
3 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..99838e4e0467
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = chezmoi_modify_manager-git
+ pkgdesc = Tools for chezmoi to handle mixed settings and state
+ pkgver = v2.0.0.alpha1.r18.538e540
+ pkgrel = 1
+ url = https://github.com/VorpalBlade/chezmoi_modify_manager
+ arch = x86_64
+ arch = i686
+ arch = armv7
+ arch = aarch64
+ license = GPL3
+ makedepends = cargo
+ makedepends = git
+ depends = openssl
+ provides = chezmoi_modify_manager
+ conflicts = chezmoi_modify_manager
+ source = chezmoi_modify_manager::git+https://github.com/VorpalBlade/chezmoi_modify_manager#branch=v2
+ md5sums = SKIP
+
+pkgname = chezmoi_modify_manager-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..63f53f4f258e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.tar.gz
+*.tar.zst
+chezmoi_modify_manager/
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a1cd6f49cad5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Arvid Norlander <VorpalBlade@users.noreply.github.com>
+pkgname=chezmoi_modify_manager-git
+pkgver=v2.0.0.alpha1.r18.538e540
+pkgrel=1
+pkgdesc="Tools for chezmoi to handle mixed settings and state"
+arch=(x86_64 i686 armv7 aarch64)
+url="https://github.com/VorpalBlade/chezmoi_modify_manager"
+license=('GPL3')
+depends=('openssl')
+makedepends=('cargo' 'git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+install=
+source=('chezmoi_modify_manager::git+https://github.com/VorpalBlade/chezmoi_modify_manager#branch=v2')
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+ export RUSTUP_TOOLCHAIN=stable
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release --all-features
+}
+
+check() {
+ cd "$srcdir/${pkgname%-git}"
+ export RUSTUP_TOOLCHAIN=stable
+ cargo test --frozen --all-features
+}
+
+package() {
+ local _cmd_name="target/release/${pkgname%-git}"
+ cd "$srcdir/${pkgname%-git}"
+ install -Dm0755 -t "$pkgdir/usr/bin/" "$_cmd_name"
+ mkdir -p "$pkgdir/usr/share/bash-completion/completions/"
+ mkdir -p "$pkgdir/usr/share/zsh/site-functions/"
+ "$_cmd_name" --bpaf-complete-style-zsh > "$pkgdir/usr/share/zsh/site-functions/_${pkgname%-git}"
+ "$_cmd_name" --bpaf-complete-style-bash > "$pkgdir/usr/share/bash-completion/completions/${pkgname%-git}"
+ # TODO: Where do completions for these go?
+ #"$_cmd_name" --bpaf-complete-style-fish
+ #"$_cmd_name" --bpaf-complete-style-elvish
+}