summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Westover2023-08-24 16:12:44 -0400
committerBen Westover2023-08-24 16:12:44 -0400
commit21ee3c54fd5e5120d7e5c8f35bd69234701d36c8 (patch)
treefb20f8b16e621117b60b752f5bf0dedfcc30086f
parent998ab85495c7bcad80be45ea0f2bf8616834ba57 (diff)
downloadaur-21ee3c54fd5e5120d7e5c8f35bd69234701d36c8.tar.gz
Update to 2.0.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD8
2 files changed, 12 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2797a3fea452..55276f160d71 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,22 @@
pkgbase = chia-cli-bin
pkgdesc = A new blockchain and smart transaction platform that is easier to use, more efficient, and secure. - Binary Release, Without GUI
- pkgver = 1.8.2
+ pkgver = 2.0.0
pkgrel = 1
url = https://www.chia.net/
arch = x86_64
arch = aarch64
license = Apache
+ depends = python
+ optdepends = cuda: GPU plotting and harvesting
provides = chia
provides = chia-cli
conflicts = chia
conflicts = chia-cli
replaces = chia-bin-cli
options = !strip
- source_x86_64 = https://repo.chia.net/debian/pool/main/c/chia-blockchain-cli/chia-blockchain-cli_1.8.2-1_amd64.deb
- sha256sums_x86_64 = 3cead565db2929ea8035adb024dd6d5af2ed99a24a69699c876ba4262456a72a
- source_aarch64 = https://repo.chia.net/debian/pool/main/c/chia-blockchain-cli/chia-blockchain-cli_1.8.2-1_arm64.deb
- sha256sums_aarch64 = a873cd0520062047ce7f62f59ac8e10785383d254d193fa74cfd239fe23d1d25
+ source_x86_64 = https://repo.chia.net/debian/pool/main/c/chia-blockchain-cli/chia-blockchain-cli_2.0.0-1_amd64.deb
+ sha256sums_x86_64 = 6500c9c8eefde13a0054b1ae7dee6c0e3ce1d2d89f20a467cac807dd322c3e3f
+ source_aarch64 = https://repo.chia.net/debian/pool/main/c/chia-blockchain-cli/chia-blockchain-cli_2.0.0-1_arm64.deb
+ sha256sums_aarch64 = 07e3439e294b5aa600436ccc90d4e9e851782256b789bb9f84ad82cec184a10f
pkgname = chia-cli-bin
diff --git a/PKGBUILD b/PKGBUILD
index 0ea383cc6bcc..f9b6a528b7c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,23 @@
# Maintainer: Ben Westover <kwestover.kw@gmail.com>
pkgname='chia-cli-bin'
-pkgver=1.8.2
+pkgver=2.0.0
pkgrel=1
_pkgrel=1
pkgdesc="A new blockchain and smart transaction platform that is easier to use, more efficient, and secure. - Binary Release, Without GUI"
arch=('x86_64' 'aarch64')
url="https://www.chia.net/"
license=('Apache')
+depends=('python')
+optdepends=('cuda: GPU plotting and harvesting')
conflicts=('chia' 'chia-cli')
provides=('chia' 'chia-cli')
replaces=('chia-bin-cli')
options=('!strip')
source_x86_64=("https://repo.chia.net/debian/pool/main/c/chia-blockchain-cli/chia-blockchain-cli_${pkgver}-${_pkgrel}_amd64.deb")
source_aarch64=("https://repo.chia.net/debian/pool/main/c/chia-blockchain-cli/chia-blockchain-cli_${pkgver}-${_pkgrel}_arm64.deb")
-sha256sums_x86_64=('3cead565db2929ea8035adb024dd6d5af2ed99a24a69699c876ba4262456a72a')
-sha256sums_aarch64=('a873cd0520062047ce7f62f59ac8e10785383d254d193fa74cfd239fe23d1d25')
+sha256sums_x86_64=('6500c9c8eefde13a0054b1ae7dee6c0e3ce1d2d89f20a467cac807dd322c3e3f')
+sha256sums_aarch64=('07e3439e294b5aa600436ccc90d4e9e851782256b789bb9f84ad82cec184a10f')
package() {
tar -xf data.tar.xz -C "$pkgdir"