summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Westover2021-07-12 17:48:14 -0400
committerBen Westover2021-07-12 17:48:14 -0400
commit1d187a2778495ac61ab102d5655f5c55ecb5c5e5 (patch)
treed97b21cae189dcb1dc2fdfad00e6111eef85af14
parent4955d858cbb2c2672ed136df3edf0ec9e2bd5e9b (diff)
downloadaur-1d187a2778495ac61ab102d5655f5c55ecb5c5e5.tar.gz
Update dependencies and build process
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD23
-rw-r--r--chia-git.install2
3 files changed, 21 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 17bf86485ff6..a2db9f824bed 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,21 @@
pkgbase = chia-git
pkgdesc = A new blockchain and smart transaction platform that is easier to use, more efficient, and secure.
- pkgver = 1.1.5.r41.g1c808b6c3
+ pkgver = 1.2.1.r0.gefd401ee
pkgrel = 1
url = https://www.chia.net/
install = chia-git.install
arch = x86_64
arch = aarch64
license = Apache
- makedepends = cmake
depends = python
depends = python-pip
- depends = python-websockets
- depends = python-wheel
+ depends = git
provides = chia
conflicts = chia
options = !strip
source = git+https://github.com/Chia-Network/chia-blockchain.git
+ source = git+https://github.com/Chia-Network/mozilla-ca#commit=6e8c42b3ef7d4ded22a994f9886e63f0060020bd
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = chia-git
-
diff --git a/PKGBUILD b/PKGBUILD
index e3bd83436c9a..169aee5d41f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,41 @@
# Maintainer: Ben Westover <kwestover.kw@gmail.com>
pkgname='chia-git'
-pkgver=1.1.5.r41.g1c808b6c3
+pkgver=1.2.1.r0.gefd401ee
pkgrel=1
pkgdesc="A new blockchain and smart transaction platform that is easier to use, more efficient, and secure."
arch=('x86_64' 'aarch64')
url="https://www.chia.net/"
license=('Apache')
install=chia-git.install
-depends=('python' 'python-pip' 'python-websockets' 'python-wheel')
-makedepends=('cmake')
+depends=('python' 'python-pip' 'git')
conflicts=('chia')
provides=('chia')
options=('!strip')
-source=("git+https://github.com/Chia-Network/chia-blockchain.git")
-sha256sums=('SKIP')
+source=("git+https://github.com/Chia-Network/chia-blockchain.git"
+ "git+https://github.com/Chia-Network/mozilla-ca#commit=6e8c42b3ef7d4ded22a994f9886e63f0060020bd")
+sha256sums=('SKIP'
+ 'SKIP')
pkgver() {
cd chia-blockchain
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ mv mozilla-ca chia-blockchain
+ cd chia-blockchain
+ git submodule update --init mozilla-ca
+}
+
build() {
cd chia-blockchain
python3 -m venv venv
ln -s venv/bin/activate .
- . ./activate
- pip install --extra-index-url https://pypi.chia.net/simple/ miniupnpc==2.1
+ source activate
+ pip install --upgrade pip
+ pip install wheel
+ pip install --extra-index-url https://pypi.chia.net/simple/ miniupnpc==2.2.2
pip install -e . --extra-index-url https://pypi.chia.net/simple/
}
diff --git a/chia-git.install b/chia-git.install
index 170baa373a55..ae9f9b61f5fd 100644
--- a/chia-git.install
+++ b/chia-git.install
@@ -1,3 +1,3 @@
post_install() {
- echo -e "\033[1;32m==>\033[0m \033[1mThe chia source code is installed in /opt/chia-blockchain."
+ msg2 "The chia source code is installed in /opt/chia-blockchain."
}