summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Westover2022-01-10 09:57:58 -0500
committerBen Westover2022-01-10 09:57:58 -0500
commit56d71dfe03edcac3a719f5d590257cb2406fae67 (patch)
tree9c8d9f23fdeefb8a277df1591696ce833815c444
parent178271e14faacdf5faa005e405161c00797056b7 (diff)
downloadaur-56d71dfe03edcac3a719f5d590257cb2406fae67.tar.gz
Python 3.9 dependency
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 29379b805e5e..e3dfd4906814 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,19 @@
pkgbase = chia-git
pkgdesc = A new blockchain and smart transaction platform that is easier to use, more efficient, and secure.
- pkgver = 1.2.1.r0.gefd401ee
- pkgrel = 3
+ pkgver = 1.2.11.r127.gaf0d6385b
+ pkgrel = 1
url = https://www.chia.net/
install = chia-git.install
arch = x86_64
arch = aarch64
license = Apache
- depends = python
- depends = python-pip
+ depends = python39
depends = git
provides = chia
conflicts = chia
options = !strip
source = git+https://github.com/Chia-Network/chia-blockchain.git
- source = git+https://github.com/Chia-Network/mozilla-ca#commit=6e8c42b3ef7d4ded22a994f9886e63f0060020bd
+ source = git+https://github.com/Chia-Network/mozilla-ca#commit=b1b808ab930004fc6b4afc4b248dee0a136f3f00
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 11c787f1ff65..2d1fe5ef1be2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
# Maintainer: Ben Westover <kwestover.kw@gmail.com>
pkgname='chia-git'
-pkgver=1.2.1.r0.gefd401ee
-pkgrel=3
+pkgver=1.2.11.r127.gaf0d6385b
+pkgrel=1
pkgdesc="A new blockchain and smart transaction platform that is easier to use, more efficient, and secure."
arch=('x86_64' 'aarch64')
url="https://www.chia.net/"
license=('Apache')
install=chia-git.install
-depends=('python' 'python-pip' 'git')
+depends=('python39' # https://github.com/Chia-Network/chia-blockchain/issues/8807
+ 'git')
conflicts=('chia')
provides=('chia')
options=('!strip')
source=("git+https://github.com/Chia-Network/chia-blockchain.git"
- "git+https://github.com/Chia-Network/mozilla-ca#commit=6e8c42b3ef7d4ded22a994f9886e63f0060020bd")
+ "git+https://github.com/Chia-Network/mozilla-ca#commit=b1b808ab930004fc6b4afc4b248dee0a136f3f00")
sha256sums=('SKIP'
'SKIP')
@@ -30,7 +31,7 @@ prepare() {
build() {
cd chia-blockchain
- python3 -m venv venv
+ python3.9 -m venv venv
ln -s venv/bin/activate .
source activate
pip install --upgrade pip