summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Westover2020-11-01 01:27:44 -0400
committerBen Westover2020-11-01 01:27:44 -0400
commit690b6abc266f9e81a609a12c95b86c070d9fb18d (patch)
tree6ea740d085ef14efcbb64f3592d34543ed023114
downloadaur-690b6abc266f9e81a609a12c95b86c070d9fb18d.tar.gz
Initial Commit
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD31
-rw-r--r--chia-gui.desktop9
-rwxr-xr-xchia-gui.sh5
4 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d3d3361c4720
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = chia-git
+ pkgdesc = A new blockchain and smart transaction platform that is easier to use, more efficient, and secure.
+ pkgver = b17.20201101
+ pkgrel = 1
+ url = https://www.chia.net/
+ arch = x86_64
+ arch = i686
+ arch = pentium4
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = Apache
+ makedepends = bc
+ makedepends = lsb-release
+ depends = git
+ depends = python
+ depends = npm
+ depends = nodejs
+ source = git+https://github.com/Chia-Network/chia-blockchain.git
+ source = chia-gui.desktop
+ source = chia-gui.sh
+ sha256sums = SKIP
+ sha256sums = 28e933f5196aaac8b847467392c1c2e43281a0767113b51d97ab6faaaccb42c7
+ sha256sums = d1081ad8ccc9c8f1a88b91a64655f459de10fa9adbc5d7dd4c19ce79de8299b8
+
+pkgname = chia-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3cad3e192218
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Ben Westover <kwestover.kw@gmail.com>
+
+pkgname='chia-git'
+pkgver=b17.20201101
+pkgrel=1
+pkgdesc="A new blockchain and smart transaction platform that is easier to use, more efficient, and secure."
+arch=('x86_64' 'i686' 'pentium4' 'armv6h' 'armv7h' 'aarch64')
+url="https://www.chia.net/"
+license=('Apache')
+depends=('git' 'python' 'npm' 'nodejs')
+makedepends=('bc' 'lsb-release')
+source=("git+https://github.com/Chia-Network/chia-blockchain.git"
+ "chia-gui.desktop"
+ "chia-gui.sh")
+sha256sums=('SKIP'
+ '28e933f5196aaac8b847467392c1c2e43281a0767113b51d97ab6faaaccb42c7'
+ 'd1081ad8ccc9c8f1a88b91a64655f459de10fa9adbc5d7dd4c19ce79de8299b8')
+
+build() {
+ cd chia-blockchain
+ sh install.sh
+ . ./activate
+ sh install-gui.sh
+}
+
+package() {
+ install -Dm644 chia-blockchain/electron-react/src/assets/img/circle-cropped.png "$pkgdir"/usr/share/pixmaps/chia.png
+ mkdir -p "$pkgdir"/opt
+ mv chia-blockchain "$pkgdir"/opt
+ install -Dm755 chia-gui.sh "$pkgdir"/usr/bin/chia-gui
+}
diff --git a/chia-gui.desktop b/chia-gui.desktop
new file mode 100644
index 000000000000..d45609ff3821
--- /dev/null
+++ b/chia-gui.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Version=1.0
+Name=Chia
+Comment=Connect to the BitcoinHD P2P Network
+Exec=chia-gui %u
+Terminal=false
+Type=Application
+Icon=/usr/share/pixmaps/chia.png
+Categories=Office;Finance;P2P;Network;
diff --git a/chia-gui.sh b/chia-gui.sh
new file mode 100755
index 000000000000..3416964b9253
--- /dev/null
+++ b/chia-gui.sh
@@ -0,0 +1,5 @@
+#!/bin/bash
+cd /opt/chia-blockchain
+. ./activate
+cd /opt/chia-blockchain/electron-react
+npm run electron