summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Westover2020-11-01 13:15:00 -0500
committerBen Westover2020-11-01 13:15:00 -0500
commit7208c64c5a3f6b2bd413f503dc47387496c4cb77 (patch)
tree509b3d6f4ff8c5abb5a6bd830d065338c5685cff
parent690b6abc266f9e81a609a12c95b86c070d9fb18d (diff)
downloadaur-7208c64c5a3f6b2bd413f503dc47387496c4cb77.tar.gz
Update pkgver function, optimize build function
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD20
2 files changed, 18 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d3d3361c4720..cb6cc6d0512a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = chia-git
pkgdesc = A new blockchain and smart transaction platform that is easier to use, more efficient, and secure.
- pkgver = b17.20201101
+ pkgver = 1.0beta17.r0.gf745601d
pkgrel = 1
url = https://www.chia.net/
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 3cad3e192218..e552b7b46dda 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Ben Westover <kwestover.kw@gmail.com>
pkgname='chia-git'
-pkgver=b17.20201101
+pkgver=1.0beta17.r0.gf745601d
pkgrel=1
pkgdesc="A new blockchain and smart transaction platform that is easier to use, more efficient, and secure."
arch=('x86_64' 'i686' 'pentium4' 'armv6h' 'armv7h' 'aarch64')
@@ -9,6 +9,7 @@ url="https://www.chia.net/"
license=('Apache')
depends=('git' 'python' 'npm' 'nodejs')
makedepends=('bc' 'lsb-release')
+options=('!strip')
source=("git+https://github.com/Chia-Network/chia-blockchain.git"
"chia-gui.desktop"
"chia-gui.sh")
@@ -16,11 +17,24 @@ sha256sums=('SKIP'
'28e933f5196aaac8b847467392c1c2e43281a0767113b51d97ab6faaaccb42c7'
'd1081ad8ccc9c8f1a88b91a64655f459de10fa9adbc5d7dd4c19ce79de8299b8')
+pkgver() {
+ cd chia-blockchain
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
build() {
cd chia-blockchain
- sh install.sh
+ python3 -m venv venv
+ ln -s venv/bin/activate .
. ./activate
- sh install-gui.sh
+ pip install --upgrade pip
+ pip install wheel
+ pip install --extra-index-url https://download.chia.net/simple/ miniupnpc==2.1 setproctitle==1.1.10 cbor2==5.1.2
+ pip install -e .
+ cd electron-react
+ npm install
+ npm audit fix
+ npm run build
}
package() {