summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Westover2021-04-17 22:22:16 -0400
committerBen Westover2021-04-17 22:22:16 -0400
commit9fc2268e0ceb03688ed8d0f4ecaa71c32e40031b (patch)
tree6ed0f472df53ce7f30247b4e69c7194567f59f77
parentbfce3e1d0cb70ffdca6dc658e2133c38b340d2ec (diff)
downloadaur-9fc2268e0ceb03688ed8d0f4ecaa71c32e40031b.tar.gz
Fix Dependency and Source issues, mention where source code is stored
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--chia-git.install3
3 files changed, 11 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3242f7576206..d1e3161d4be4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = chia-git
pkgdesc = A new blockchain and smart transaction platform that is easier to use, more efficient, and secure.
- pkgver = 1.0rc2.r0.g6518b2bf
+ pkgver = 1.0.0.r158.gf1be1714
pkgrel = 1
url = https://www.chia.net/
+ install = chia-git.install
arch = x86_64
arch = i686
arch = armv7h
@@ -11,6 +12,7 @@ pkgbase = chia-git
makedepends = cmake
depends = git
depends = python
+ depends = python-websockets
provides = chia
conflicts = chia
options = !strip
diff --git a/PKGBUILD b/PKGBUILD
index 8b4e20954a48..f5e6c8c28569 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,14 @@
# Maintainer: Ben Westover <kwestover.kw@gmail.com>
pkgname='chia-git'
-pkgver=1.0rc2.r0.g6518b2bf
+pkgver=1.0.0.r158.gf1be1714d
pkgrel=1
pkgdesc="A new blockchain and smart transaction platform that is easier to use, more efficient, and secure."
arch=('x86_64' 'i686' 'armv7h' 'aarch64')
url="https://www.chia.net/"
license=('Apache')
-depends=('git' 'python')
+install=chia-git.install
+depends=('git' 'python' 'python-websockets')
makedepends=('cmake')
conflicts=('chia')
provides=('chia')
@@ -27,8 +28,8 @@ build() {
. ./activate
pip install --upgrade pip
pip install wheel
- pip install --extra-index-url https://download.chia.net/simple/ miniupnpc==2.1
- pip install -e . --extra-index-url https://download.chia.net/simple/
+ pip install https://download-chia-net.s3-us-west-2.amazonaws.com/simple/miniupnpc/miniupnpc-2.1.tar.gz
+ pip install -e .
}
package() {
diff --git a/chia-git.install b/chia-git.install
new file mode 100644
index 000000000000..3019e7b6f31d
--- /dev/null
+++ b/chia-git.install
@@ -0,0 +1,3 @@
+post_install() {
+ echo "The chia source code is installed in /opt/chia-blockchain."
+}