summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Westover2021-02-24 20:27:04 -0500
committerBen Westover2021-02-24 20:27:04 -0500
commitbfce3e1d0cb70ffdca6dc658e2133c38b340d2ec (patch)
treeee244af4c3b42d759aa63e208e45d47f270a695b
parent0df20297ed29bda3b3cb626d0750c1b6a886f050 (diff)
downloadaur-bfce3e1d0cb70ffdca6dc658e2133c38b340d2ec.tar.gz
Update to rc2 (gui is now a separate package chia-gui-git)
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD35
-rw-r--r--chia-gui.desktop9
-rwxr-xr-xchia-gui.sh5
4 files changed, 11 insertions, 52 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b2fee9c3eeb5..3242f7576206 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,29 +1,21 @@
pkgbase = chia-git
pkgdesc = A new blockchain and smart transaction platform that is easier to use, more efficient, and secure.
- pkgver = 1.0beta21.r0.g93adb84f
+ pkgver = 1.0rc2.r0.g6518b2bf
pkgrel = 1
url = https://www.chia.net/
arch = x86_64
arch = i686
- arch = pentium4
- arch = armv6h
arch = armv7h
arch = aarch64
license = Apache
makedepends = cmake
depends = git
depends = python
- depends = git
- depends = python
- depends = npm
- depends = nodejs
+ provides = chia
+ conflicts = chia
options = !strip
source = git+https://github.com/Chia-Network/chia-blockchain.git
- source = chia-gui.desktop
- source = chia-gui.sh
sha256sums = SKIP
- sha256sums = 28e933f5196aaac8b847467392c1c2e43281a0767113b51d97ab6faaaccb42c7
- sha256sums = d1081ad8ccc9c8f1a88b91a64655f459de10fa9adbc5d7dd4c19ce79de8299b8
pkgname = chia-git
diff --git a/PKGBUILD b/PKGBUILD
index 63f416efab6b..8b4e20954a48 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,19 @@
# Maintainer: Ben Westover <kwestover.kw@gmail.com>
-# Uncomment to install GUI
-# _install-gui=y
-
pkgname='chia-git'
-pkgver=1.0beta21.r0.g93adb84f
+pkgver=1.0rc2.r0.g6518b2bf
pkgrel=1
pkgdesc="A new blockchain and smart transaction platform that is easier to use, more efficient, and secure."
-arch=('x86_64' 'i686' 'pentium4' 'armv6h' 'armv7h' 'aarch64')
+arch=('x86_64' 'i686' 'armv7h' 'aarch64')
url="https://www.chia.net/"
license=('Apache')
depends=('git' 'python')
-if [ -n "${_install-gui}" ]; then
- depends+=('git' 'python' 'npm' 'nodejs')
-fi
makedepends=('cmake')
+conflicts=('chia')
+provides=('chia')
options=('!strip')
-source=("git+https://github.com/Chia-Network/chia-blockchain.git"
- "chia-gui.desktop"
- "chia-gui.sh")
-sha256sums=('SKIP'
- '28e933f5196aaac8b847467392c1c2e43281a0767113b51d97ab6faaaccb42c7'
- 'd1081ad8ccc9c8f1a88b91a64655f459de10fa9adbc5d7dd4c19ce79de8299b8')
+source=("git+https://github.com/Chia-Network/chia-blockchain.git")
+sha256sums=('SKIP')
pkgver() {
cd chia-blockchain
@@ -35,22 +27,11 @@ build() {
. ./activate
pip install --upgrade pip
pip install wheel
- pip install --extra-index-url https://download.chia.net/simple/ miniupnpc==2.1 setproctitle==1.1.10 cbor2==5.1.2
- pip install -e .
- if [ -n "${_install-gui}" ]; then
- cd electron-react
- npm install
- npm audit fix
- npm run build
- fi
+ pip install --extra-index-url https://download.chia.net/simple/ miniupnpc==2.1
+ pip install -e . --extra-index-url https://download.chia.net/simple/
}
package() {
- if [ -n "${_install-gui}" ]; then
- install -Dm644 chia-blockchain/electron-react/src/assets/img/circle-cropped.png "$pkgdir"/usr/share/pixmaps/chia.png
- install -Dm755 chia-gui.sh "$pkgdir"/usr/bin/chia-gui
- install -Dm644 chia-gui.desktop "$pkgdir"/usr/share/applications/chia-gui.desktop
- fi
mkdir -p "$pkgdir"/opt
mv chia-blockchain "$pkgdir"/opt
}
diff --git a/chia-gui.desktop b/chia-gui.desktop
deleted file mode 100644
index d45609ff3821..000000000000
--- a/chia-gui.desktop
+++ /dev/null
@@ -1,9 +0,0 @@
-[Desktop Entry]
-Version=1.0
-Name=Chia
-Comment=Connect to the BitcoinHD P2P Network
-Exec=chia-gui %u
-Terminal=false
-Type=Application
-Icon=/usr/share/pixmaps/chia.png
-Categories=Office;Finance;P2P;Network;
diff --git a/chia-gui.sh b/chia-gui.sh
deleted file mode 100755
index 3416964b9253..000000000000
--- a/chia-gui.sh
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/bin/bash
-cd /opt/chia-blockchain
-. ./activate
-cd /opt/chia-blockchain/electron-react
-npm run electron