summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Westover2021-04-25 20:13:58 -0400
committerBen Westover2021-04-25 20:13:58 -0400
commitfc16a706ad0037c3a66d9f6ad83ba663e2052af0 (patch)
tree4aa6f45441cd8ff42c7fa0e36ca2374a97fc531c
parent9fc2268e0ceb03688ed8d0f4ecaa71c32e40031b (diff)
downloadaur-fc16a706ad0037c3a66d9f6ad83ba663e2052af0.tar.gz
Fix Dependencies
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD6
-rw-r--r--chia-git.install2
3 files changed, 6 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d1e3161d4be4..498f17cad18b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = chia-git
pkgdesc = A new blockchain and smart transaction platform that is easier to use, more efficient, and secure.
- pkgver = 1.0.0.r158.gf1be1714
+ pkgver = 1.1.1.r14.ge7304c59
pkgrel = 1
url = https://www.chia.net/
install = chia-git.install
@@ -10,9 +10,10 @@ pkgbase = chia-git
arch = aarch64
license = Apache
makedepends = cmake
- depends = git
depends = python
+ depends = python-pip
depends = python-websockets
+ depends = python-wheel
provides = chia
conflicts = chia
options = !strip
diff --git a/PKGBUILD b/PKGBUILD
index f5e6c8c28569..4d5372e29a36 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Ben Westover <kwestover.kw@gmail.com>
pkgname='chia-git'
-pkgver=1.0.0.r158.gf1be1714d
+pkgver=1.1.1.r14.ge7304c59
pkgrel=1
pkgdesc="A new blockchain and smart transaction platform that is easier to use, more efficient, and secure."
arch=('x86_64' 'i686' 'armv7h' 'aarch64')
url="https://www.chia.net/"
license=('Apache')
install=chia-git.install
-depends=('git' 'python' 'python-websockets')
+depends=('python' 'python-pip' 'python-websockets' 'python-wheel')
makedepends=('cmake')
conflicts=('chia')
provides=('chia')
@@ -26,8 +26,6 @@ build() {
python3 -m venv venv
ln -s venv/bin/activate .
. ./activate
- pip install --upgrade pip
- pip install wheel
pip install https://download-chia-net.s3-us-west-2.amazonaws.com/simple/miniupnpc/miniupnpc-2.1.tar.gz
pip install -e .
}
diff --git a/chia-git.install b/chia-git.install
index 3019e7b6f31d..bb91a450ebaf 100644
--- a/chia-git.install
+++ b/chia-git.install
@@ -1,3 +1,3 @@
post_install() {
- echo "The chia source code is installed in /opt/chia-blockchain."
+ echo -e "\033[0;32m==\033[0m> \033[1mThe chia source code is installed in /opt/chia-blockchain."
}